iCloud Vault gone

What I’m trying to do

I don’t expect a solution to this as from my initial searches it seems storing the vault in the cloud is a no go. I just wanted to bring some awareness to others who may store it there you might have this unexpected result as well.

I opened up my MacBook like normal and tried to do a journal entry when my vault said ‘file not found’
I tried opening other files in the vault and they all said the same thing.
I tried re-opening the vault to find the vault files completely gone but the path was still there.
I re-started my computer and now the path has been erased as well.
I tried looking in the computer’s trash but there is nothing, I tried looking in my iCloud Drive trash and nothing.
I tried searching for any of the file names on my MacBook and nothing.
I do not have Time Machine enabled on because it is fairly new and haven’t gotten around to it.
It’s almost as if I never had the vault in the first place and it was all a dream.

I don’t know what resources you found, but using iCloud should work OK as long as you don’t use it on Windows. What you describe isn’t normal.

Here are some things to try:

  • In the vault, check in Settings > File Recovery.
  • Look in the vault folder in Finder (I know you already searched for filenames so this may. It accomplish much but at least you’ll sure).
  • Were you syncing to another device, and if so does that device have your vault?
  • Log into iCloud on the web and check there.

(And of course in future, setup Time Machine earlier.)

Just to rule that out, you haven’t opened the sandbox vault? Where any changes will be erased when you shutdown, and reopen Obsidian?

Do you see all the introduction files when you start Obsidian?

1 Like
  • I cannot do File Recovery for the vault as the ability to see it has vanished after I restarted my computer.

  • I have Raycast on my Mac and searched possible filenames and looked through every single folder as I don’t have much on this computer and found nothing.

  • The only thing I can think of as a possibility is I got a new iPhone and hard reset my old one to send it back, but every single thing besides the vault is on my new iPhone and I had also accessed my vault after this process had taken place.

  • I don’t have sync, it was just where I had chose to store my vault.

  • I logged in to iCloud and there is nothing in the drive folder or the deleted folder as well.

  • I believe I just cut my losses on the vault and ensure in the future I create backups regularly as it was over 6 months of daily entries.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.