I deleted a pinned note and now I have a pinned empty space

Steps to reproduce

As per the title, I deleted a note that was pinned to the editor (using right click in files) and now I have an empty space pinned. Resetting the app doesn’t solve the issue

Expected result

New notes should open here

Actual result

Empty Spaces


  • Operating system: MacOS 10.15.5
  • Obsidian version: 0.6.7
  • Using custom CSS: Comfort color dark theme + Andy Matuschak mode V2

Does this happen with the default CSS?

Yeah, just dropped it out and still having the same issue.

Thanks. We have made some changes to the pinned system in 0.7. Please, let me know if you still have this issue when we release it.

Cool, have tried rebooting the machine and uninstalling/ reinstalling the app and still having the same issue.

Any idea how I can mitigate until the next release?

Can you use Ctrl-W to close the current pane.
Or use assign a schorcut to close all other panes

Thanks, I created a close all panes shortcut which seemed to do the trick.

I am still quite puzzled by your bug. But good that is solved.

It’s a weird one. Have tried to replicate it and get’s the same results each time.

you mean you can replicate it all the time?

Yeah, same results each time.

Thanks. Let me know how 0.7 goes.

Will do.