I cannot create new files/folder inside ANY vault!

I have never had issues with Obsidian, until now, I cannot open a common folder that was always there, I mean I cannot even create new files or folders inside ANY vault. It’s throwing an error that was not there. Besides I did not change anything on Obsidian, still the same configuration, the same location, and now a surprisingly error.

OS: Windows 11 Pro (original)
Obsidian: last version

Steps

  1. Open Obsidian from Start Menu
  2. The vault is automatically opened, (is possible to read files)
  3. Every time I try to create a new file/folder,
    – by clicking top icon, or CTRL+N or clicking "Create new Note (Ctrl + N)
  4. The following error shows up:

Error ENOENT: no such file or Directory, open C:\Users\UserXXX\Documents\_DOCS\OBSIDIAN\001 - PERSONAL\Untitled.md

The problem went away yesterday when I restarted Windows. But it returned!

Is that ..\Documents\_DOCS\.. folder watched by OneDrive, GoogleDrive,
or anything like that? If a sync service off-loaded the files, you will get that error.

The ENOENT error tends the mean the files aren’t actually on the disk.

forum search: Search results for 'ENOENT order:latest' - Obsidian Forum

A few of the ENONET posts also mention not being able to read & write the files properly.

You could try with a text/code editor to open and edit a few of the .md files to see what happens.

Wrong! The locations are correct!!

Documents is TARGETed at C:\Users\UserXXX\Documents

  • There is no Google Drive, nor Onedrive synced to it.
  • And I have SSD 1 TB of space
  • Characters limit is bypassed both using REGEDIT and GPEDIT.MSC.
  • There is no Antivirus activated
  • I have admin rights
  • I have full folder’s permission
  • I tried to reinstall Obsidian 3x times
  • I tried to erase obsidian %localappdata% and roaming folders
  • I temporary deleted .obsidian Vault folder (did not work)
  • I tried to create another Vault and transfer files (didn’t work)
  • Obsidian is installed on C:\ and Vault is also on C:\

I hope I could find an answer, it all started after the last update.

I managed to do that, with vscode and notepad and both worked as expected! Not a r, rw issue

Here is the funny thing. Obsidian is working all of sudden again!

But as I mentioned above, it works for a time and then it doesn’t work again.

I believe is some sort of bug from Obsidian. Maybe two processes trying to access the same file ?

If you don’t already have a backup system setup, I’d recommend doing it now.

1 Like

The problem is BACK! :man_facepalming:

FINALLY! I found the solution!

I deactivated Security > Ransomware Protection, I didn’t know it was activated! I guess because Windows Update,

I hope I shed some light to some lost user like me who had the same problem,

1 Like

You may want to look into what that was the solution, so that you might be able to find a better one. But congrats on finding that!

I am having no issues so far 'till now! Thanks!

Right, I just meant “better” in the sense of “doesn’t require disabling a security feature”.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.