How to stop © autocomplete in obsidian

Things I have tried

I tried deleting but it deletes the whole ©

What I’m trying to do

This is likely a setting in your operating system. What OS are you using?

What are you trying to type? “(c)”?

I am trying to write sometimes ( C) for carbon for example
or sometimes, i even tried writing (Canada) for example and it ends up like this
©anada). I am using mac. Thank you for the answer!

Go to System Preferences → Keyboard → Text

There, you might see an entry for ©. You should be able to disable it there. If not, maybe you have another snippet/expander app installed?