How to select a note without the double brackets automatically closing (with pipe & custom text)

Minor issue:
Sometimes I make a link to a note with the pipe | e.g. [[File name|Custom text]], and sometimes I want to change the note contained in File name but not the Custom text itself. Or sometimes there’s a link to a previously-not-existing note [[|Custom text]], and now I’ve created it and want to link to it plus keep the custom text.

When I select the note from auto-complete and press enter, it closes the brackets right after the file name and right before the pipe even though the two closing brackets ]] are already there at the end of the custom text.

I want to keep the custom text; to do so, I’d have to backspace the two brackets before the pipe every time.

Is there a way to select the note without that auto-pair happening? Now, I personally use the auto-pairing feature a lot so I don’t want to disable it entirely, it’s just for when there’s custom text.

If this isn’t a feature yet, I’ll make a request after this post gets archived.

4 Likes

I think there’s value here, but I’m not sure it’s a feature request or a bug report.

Any chance you can do a screen record of the problematic behaviour?

Here’s a gif:


Does that explain it?

It’s pretty minor, I wouldn’t say it’s unbearably problematic, just inconvenient.

I wouldn’t say it’s a bug. I mean, auto-pair is pretty much doing what it’s supposed to. But in this context, I’d want it to not auto-pair when the file contained in a link with custom text is being edited, if you know what I mean.

I suppose this is a feature request. The reason this post is in the Help category is that maybe there’s already a key I can press that can allow me to select a note while temporarily disabling auto-pairing… idk.

3 Likes

Suggest you move this one into bugs. Also annoys me.

1 Like

No key exists for that, far as I know.

I’d also classify this as a bug. The app should recognize that you’re already inside a pair of double brackets. Let me know if you’re okay with that!

Have made a bug report on this:

2 Likes

If instead of presing enter or clicking on the note you press TAB it works as you want to.

1 Like