How to Remove massive window heads in 1.0

I work on a laptop with fairly limited vertical screen space; with the update to 1.0, obsidian has added new top and bottom margins to my window which take up about 10% of my total vertical screen space that would otherwise be used to display text. I’m just wondering how I could disable the new margins on the top and bottom of the obsidian window. Additionally, is there any way for me to remove the bezeled edges?

(Also, the update to 1.0 has ruined my visual set up for obsidian in general, so if anyone has a way for me to just revert to the old obsidian look without simultaneously having to watch all of my plugins slowly grow outdated, that would be fantastic.)

1 Like

A few ways to reclaim vertical screen space:

  • Settings > Appearance > Show inline title > disable
  • Settings > Appearance > Show tab title bar > disable
  • Settings > Appearance > Window frame style > Hidden

Also, this plugin can hide several other UI elements: GitHub - kepano/obsidian-hider: Hide Obsidian UI elements such as tooltips, status, titlebar and more

Edit to add: another option to look at is “Focus mode” in Minimal Theme, which can be enabled using the Minimal Theme Settings plugin.

3 Likes

In addition to the UI tweaks Sentiment suggested and the FAQ in the release notes, you might share a screen shot of what you are seeing.

What you are describing doesn’t sound right
though with top and bottom margins. It might be an outdated theme or snippet.

Can you post a screenshot? Sounds like it could be some bug as well.

Make sure your installer is up to date (at least 0.15.9), plugins are updated, theme is updated, etc.

Not the OP but I too am having a heck of a time with the giant headers in edit mode. I have this snippet enabled.

/* make all headers the same size */

h1, h2, h3, h4, h5, h6 {
    font-size:  18px !important; 
}

/* make all headers in preview the same size */

.markdown-preview-view h1,
.markdown-preview-view h2,
.markdown-preview-view h3,
.markdown-preview-view h4,
.markdown-preview-view h5,
.markdown-preview-view h6 {
    font-size: 1em;
}


/* editor headers */

.cm-header {
    font-size: 1em;
}

What used to happen is that in both edit and readermode things were all the same size, just different colors.

Now this is what it’s like in edit mode
Screen Shot 2022-10-13 at 9.03.17 PM

And this is what it looks like in reader mode
Screen Shot 2022-10-13 at 9.04.29 PM

I want to get it back to the same size no matter what mode I am in.

Related is that I can change the font size of the notes using appearance font size but the sidebar font seems to stay the same and it’s way too small. How do I increase the sidebar font size?

1 Like

Do these work in your theme?

/* headers editing mode */
.HyperMD-header .cm-header-1,
.HyperMD-header .cm-header-2,
.HyperMD-header .cm-header-3,
.HyperMD-header .cm-header-4,
.HyperMD-header .cm-header-5,
.HyperMD-header .cm-header-6 {
  font-size: 1rem !important;
}

/* headers reading mode */
.markdown-rendered h1,
.markdown-rendered h2,
.markdown-rendered h3,
.markdown-rendered h4,
.markdown-rendered h5,
.markdown-rendered h6 {
  font-size: 1rem !important;
}
1 Like

That works to solve the header sicze problem, THANKS!

Still can’t make the sidebar font larger though.

Use the Zoom level in Appearance settings for the sidebar font size then set the editor font size with control + mouse wheel.

1 Like

That part works to fix the side bar font size.

Control and mouse wheel zooms my entire screen in and out but does not change the font size in editor. It also makes all the operating system stuff on the edges disappear off the sides.

Ok, 2 settings about the zoom line there is one called font size which affects the editing and reading views. That might be what you need.

I’ve already done all of these, resulting in a marginal improvement, not the issue that I’ve written about but thank you for the suggestions.


Here’s an image of my vault currently, both the top bar and the bottom bar used to be much smaller, I’ve tested a variety of minimal themes and nothing seems to change, in fact, most minimal themes actually make the bar larger to fit in with the window handling buttons in the top right.

Are you sure?

I’m able to improve the top part (fyi looks like “native frame”, at least on Win10, is actually smaller than “hidden”), as well as totally hide the bottom part.

1 Like

Yeah, I’ve tried the windows native frame but it’s still significantly larger (and significantly uglier) than what used to be the default in obsidian, which I have attached an example of from the blue topaz repository, whose theme I use.

I’ve enabled the ‘hider’ plugin which seems to work as a temporary fix, but it’s still far from preferable to just being able to enable the old obsidian look.