How to remove a plugin

I suspect that some keys quit working when I added the plugin Note Refractor. These are the capltal letters of <, >, ?. I want to test to see if the plugin is related to the problem, but I do not know how to remove it.

After I added the plugin Note Refractor, I noticed that some keys to not work. <,> ? Are all upper case next to _ and shift on the right hand side. Those “upper cases” keys do not work. I do not know if happened because of the plug in which also does not seem to work, so I disabled the Note Refactor plug in.

The keyboard uses the program called Karabiner-elements to adjust it to my iMac 2012.

I notice there are other keyboard issues in Russian. This is a Japanese language keyboard.

Is this a double post, or did you successfully remove the Note Refactor plugin? I combined your two separate topics. If something changed, you can edit your existing post, or reply, rather than post two nearly identical ones.

Do those keys work as expected in other text editors or input fields?

1 Like

I am trying to figure out how to remove it as a test. If it is not the cause of the problem, I really would like to be able to use it.

Yes the keys work in every other application other than my Obsidian. The problem also occurs when I use the blue tooth keyboard that comes with the Mac. But again, it is a Japanese keyboard. It is made to easily switch over to Japanese imputes.

Sorry about double posts. When I get no reply, I think I have stated the problem in a confusing way or it is located in the wrong place in the forum. I do not know how to merge posts. Sorry. I should learn.

Well hopefully someone answers you. I don’t know how to remove 3rd party plugins, because I’ve still never tried installing any.

But you can find your Obsidian preferences here. Maybe you can find a clear folder for the Note Refactor plugin in here:

~/Library/Application Support/obsidian/

Also this may be relevant. In Obsidian 0.10.3 the way keyboard shortcuts work was changed.

Hotkeys have been completely revamped to always use keyboard layout independent mode.

What version of Obsidian are you currently using?

You can remove plugins by going to Settings > Community plugins > Click the X next to the plugin you wish to remove. If you just want to turn it off without uninstalling it, just click the on/off switch to turn it off.

You also may need to restart Obsidian depending on the plugin, since some of them don’t unload correctly.

If you’ve disabled a plugin and the problem persists, it’s not the plugin.

There’s no chance you’ve entered VIM mode again, is there?

I wish that were the problem. It fixed the keys not typing problem before. I crossed the x next to the plug in, restarted Obsidian. The problem was not fixed. The problem may be related to my computer keyboard being Japanese language keys working. I reported it as a possible problem. So, I guess I did as much as is possible for me.

Could you post a screenshot of what you mean by “crossed the x next to the plug in”? I can’t imagine what you mean by this.

1 Like

Sorry. This is what I mean. Click on this x to get rid of the plugin.Screen Shot 2021-02-26 at 12.15.27
The keyboard keys not working problem does not change at least the plugin that I removed is not the problem.

Ah ok, I see. I don’t have those Xs in mine, perhaps because of my theme. Mine looks like this.

image

I have no further ideas right now, sorry.

Thanks

There hasn’t been any activity for 5 days, could you please see if you’d like to pick any of the existing answers as the solution, or do you still need help with something?

Would appreciate it if you could clarify on that, thanks!