How to force obsidian to use integrated GPU

What I’m trying to do

I would like Obsidian to run on my integrated GPU instead of discrete GPU to save battery life.
My discrete GPU automatically suspends when not in use.

$ cat /sys/bus/pci/devices/0000:01:00.0/power/runtime_status

but after launching obsidian, the GPU is enabled (shows active)

Things I have tried

Tried starting Obsidian with:

VK_ICD_FILENAMES="/usr/share/vulkan/icd.d/intel_icd.x86_64.json" obsidian

which has worked for some other electron apps.
I’ve also tried adding --force_low_power_gpu which is a flag I found from this electron issue

My System

(I want to use the Intel Raptor Lake-P [Iris Xe Graphics])

Figured it out. I added all of these flags: --force_low_power_gpu --gpu-active-vendor-id=0x8086 --gpu-active-device-id=0xa7a0

You can find the vendor and device ID from lspci -nn in the brackets.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.