How do I edit the frontmatter YAML in live preview mode?

My Obsidian software just updated to 1.4 and I noticed the properties feature.

But I cannot figure out how to edit the frontmatter YAML in live preview mode. Is there some setting I have turn on/off?

Or is this not longer possible? If that is the case then I just want to say that it feels as a breach of contract. My expectation is/was that Live Preview would allow me to see (preview) something beautiful whereas I could always edit the raw text file. This transparency and close connection to the actual file content is a main motivator for me using Obsidian. It is just text, it is just markdown, and it is right there.

PS. On a more practical note, it is always annoying when software always seems to assume that everyone wants their date formatted as someone living in the US.

EDIT: I discovered this Feature Request which seems to indicate that it as I feared. But the feature request is closed (after just 7 days of inactivity, even though the thread is full of people asking to add the feature? I am not very active on this forum but it feels like a high bar to expect people to post in a thread everyday and otherwise close it? I hadn’t even seen this new feature until today)

Settings > Editor > Properties in document -> Source


Thank you, thank you. I will close this now.

Just one more thought, for the core devs: I see that I am not the only one getting shocked by this update. I really think it would have been a good idea to communicate how to do this in the release notes directly. People are so invested into their notes (which is a good thing, right? We love Obsidian) so when changes like this just come out of the blue (which is our experience) without any pointers on how to keep it the way it was, it will feel … not good.

1 Like

As of the latest patch, this appears to be broken? I have (and have had) the Properties in document set to source, and it’s pretty important to my workflows. As of this update I can no longer edit them even if I turn off the properties plugin; I seem to have to exit live preview. Is there another setting or a new one that I have not been able to find? Thanks.

The sudden changes happening with properties are very disconcerting. I keep having to tweak what was once a very simple workflow because, you know, it’s just a text file. Except now part of that text file isn’t being treated that way. And turning off the properties plugin didn’t help.

Yes, this is a known bug of the v1.4.8 (Catalyst release) which will be fixed in the next release.

I suppose if I can’t handle bugs I should get off the preview train, huh?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.