How can I open an Obsidian URIs from Google-Chrome in Cent OS 8?

Things I have tried

I have unpacked Obsidian-0.12.19.AppImage
under /run/media/$USER/Obsidian
and that has created the folder squashfs-root within /run/media/$USER/Obsidian.

I have created a file called obsidian.desktop with the following content within /home/$USER/.local/share/applications:

[Desktop Entry]
Comment=Run Obsidian
Exec=bash -c ‘/run/media/$USER/Obsidian/squashfs-root/AppRun’ %u

I have run sudo update-desktop-database afterwards.
Now I can open Obsidian by means of an URI’s vault either by using Firefox GUI or the terminal command xdg-open.

Nonetheless I still see two problems:

  1. Firefox does not open URIs from particular notes. If I copy and past the URI of an Obsidian note within Firefox URL bar, then the corresponding Obsidian vault gets open at the same note I left it the last time I closed it.
  2. Google-chrome does not even open URIs of vaults. Moreover, there is not popup dialog when I visit this URI addresses from Google-Chrome.

It seems someone else already described the problem with Google-Chrome on the link below:

What I’m trying to do

I am trying to open an Obsidian URI from Google-Chrome.

1 Like

One of the two problems described in my first post got fixed.

I do not really know how the problem described for Google-Chrome got fixed. I just remember doing the following steps:

  1. commenting out the following line from ~/.config/mimeapps.list
  2. adding the following bookmark, within Google-Chrome, to the vault:
  3. At this point I already tried to open obsidian from the bookmark I created in Google-chrome and it worked fine.
  4. Then I added back the line that I commented in the step one:
  5. Now I see the bookmark still works in Google-Chrome as well.

Now what I see when I type the vault address in Google Chrome address bar is as follows:

As you can see there is a third line to open the link with Obsidian. I think this last entry was missing before.

Anyway there is something that still does not work in any of the browsers I mentioned in the first post: Google-Chrome and Firefox. I cannot open a particular note. Moreover I cannot even open a particular vault even if I type the link to that vault in Google-Chrome or Firefox URL bar. Obsidian gets just open on the last vault that was open the last time I closed it regardless of the particular link I might be using on the address bar of the browser. Do you know how to fix this?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.