How can I get open link and reveal in navigation (in 3 dots menu) to work correctly, when using ? Am I missing a setting?

When I have installed and Spaces enabled, the open link context menu seen with a note file in edit mode when right clicking a link just above a file, which is embedded in the first and stored in the vault, does not open the folder in which the embedded file is stored. (If I open the folder manually, the embedded file is highlighted.) When I disable or its SPaces option, and use the open link menu, it opens the correct sidebar folder, and the embedded file title text flashes yellow and then stays highlighted.

In a similar way, if I instead of using the “open link” menu item I go to “reveal file in navigation”, then the icon “files” at the top becomes unselected and the selection switches to “spaces”. With disabled, the sidebar folder containing the original note file is opened and the note file title flashes yellow and then stays highlighted.

What I’m trying to do

Get these two operations to work with Make md installed with Sapces enabled, if possible. (I currently have Spaces disabled.

Things I have tried

I have looked on the forum under posts, but have not seen this described - have I missed something ? have a Discord server linked from their homepage:

You might get some quick responses there.

You need to turn on Spaces Compatibility Mode in order to remove all the reveal and open events being sent to Spaces instead of Files

It is working - thanks. The strange thing is that it was not working before, on the then current version of Obsidian. It is now up to date. I tried turning on the compatibility mode, and then off again, and it is now even working with compatibility off. The only think I can fathom is that the Obsidian update fixed something. I was on Make 0.7.29 - it also works fine on 0.7.31 - … Anyway, it is all working well now - Thanks again.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.