Hotkeys doesn't register Turkish characters

I’ve been setting up my personal hotkeys in Obsidian when I came across this issue. It seems like when I’m setting up hotkeys, Obsidian ignores my keyboard layout and automatically registers the keys as it’s English Q keyboard.

Steps to reproduce

Because these local characters are not used a lot, I wanted to use them for hotkeys so that it’d also make it easier to remember. I’ve first tried it to use two of the letters (Ö and Ç) for sidebar toggles.

Expected result

I expected Obsidian to register these keys based on my physical keyboard layout and how it’s currently registered in the system. Since Obsidian never had issues with these keys before, I assumed there will be no issue.

Actual result

Instead, Obsidian registered these keys as if my keyboard layout was English Q.

First one should be Control+Ö and second one Control+Ç. Since I already have those keys physically on my keyboard and was planning to use for other hotkeys, this makes those keys unusable. Plus it causes conflicts because first one works with both Ö and , keys (interestingly, it’s not the case for . key).

Environment

  • Operating system: macOS Monterey 12.3

  • Debug info:

SYSTEM INFO:
	Obsidian version: v0.13.33
	Installer version: v0.13.30
	Operating system: Darwin Kernel Version 21.4.0: Mon Feb 21 20:36:53 PST 2022; root:xnu-8020.101.4~2/RELEASE_ARM64_T8101 21.4.0
	Login status: logged in
	Catalyst license: none
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: Minimal
	Snippets enabled: 1
	Safe mode: off
	Plugins installed: 32
	Plugins enabled: 27
		1: Kanban
		2: Citations
		3: Auto Link Title
		4: Discord Rich Presence
		5: DEVONlink
		6: Readwise Official
		7: Calendar
		8: Outliner
		9: Style Settings
		10: Dataview
		11: Advanced Tables
		12: Natural Language Dates
		13: Advanced URI
		14: Metadata Extractor
		15: Templater
		16: Charts View
		17: Contextual Typography
		18: Breadcrumbs
		19: Hider
		20: Zoom
		21: Sliding Panes (Andy's Mode)
		22: System Dark Mode
		23: Minimal Theme Settings
		24: Things Link
		25: Tasks
		26: Tag Wrangler
		27: Dynamic Highlights

RECOMMENDATIONS:
	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

I’m open to test anything else to debug and help. So feel free to ask me to try things if needed.

they appear wrong, but do they work?

Yes, when I use those keys the action assigned works as expected.

But it also causes another issue, which is that same action is partially assigned to two different keys. For some reason both Control + Ö and Control + , does the same action but in the case of Control + Ç, Control + . does nothing.

I don’t think we will fix this.

Have to say I was not sure if there was anything to be fixed when I was reporting it because it seemed like an interesting and unique issue. Definitely not something that breaks Obsidian or makes it hard to work but mainly an odd behavior.

My reason to report this was mainly to create a record of this behavior just in case it turns out to be related to something else in the future or other people with similar issues can find something online.