Homepage "Failed to load plugin manifest"?

What I’m trying to do

I am trying to load the Homepage plugin.

Things I have tried

  • I first successfully loaded the Homepage plugin in a test vault where it seems to be working properly. I then decided to try it on my Android tablet with my main vault, and I couldn’t load it. I can browse for it, but when I click on it, I get the message “Failed to load plugin manifest” and there is no description in the right hand pane. Other plugins including the “Home tab” plugin (which also comes up with a search for home) correctly show the description and give me the ability to install.

  • I then tried this on my Windows 11 desktop with my main vault. I got the same behavior.

  • Next, I went back to my test Vault on my Windows desktop. It has the Homepage app loaded, and it seems to work (I can bring it up, and I can see the options to play with). However, if I browse for it in Community Plugins and click on it, I get the same “Failed to load plugin manifest” message and the description and buttons do not appear in the right panel.

  • Someone mentioned deleting the app.json file under .obsidian, but looking at mine, it only has “vimMode”: true and “promptDelete”: false, which don’t have any bearing on the problem.

Any suggestions would be greatly appreciated. Could I just copy the Homepage plugin folder from my test vault over to my main vault to at least get the plugin installed?



If you’re talking about this one…

Screenshot 2023-04-11 110355

…I get the same error. You could manually install it from their Github page, copy the one you already have in your test vault to another vault, or wait for an update to the manifest.

Thanks! I’ll try copying it over from my test vault.



And that worked. Thanks again.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.