Home key on checkbox list item goes to next line when after an H2 or H3 title

When on a checkbox list, after an H2 or H3 title, the “home key” (command+left arrow on a Mac) behaves weirdly: it goes to next line instead of the beginning of the current line.

It works fine in any other situation, except for this case scenario (which happens to be something I do a lot).

Steps to reproduce

Create an H2 or H3 title, then a checkbox list. Then try the home key.
It goes to next line, right? (well, it does for me)
Remove the H2 or H3 title and try again. It works now! I mean: it goes to the beginning of the line as it should!
Try with an H1 or H4: It works too!

It only acts funky when after an H2 or H3 title.

Expected result

Cursor goes to the beginning of the line.

Actual result

Cursor goes to the next line.


  • Operating system: MacOs BigSur, version 11.7.4
  • Debug info:
    Obsidian version: v1.1.16
    Installer version: v1.1.9
    Operating system: Darwin Kernel Version 20.6.0: Fri Dec 16 00:35:00 PST 2022; root:xnu-7195.141.49~1/RELEASE_X86_64 20.6.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Things v2.1.6
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 10
    Plugins enabled: 6
    1: Style Settings v1.0.2
    2: Calendar v1.5.10
    3: Paste URL into selection v1.7.0
    4: Templater v1.16.0
    5: LanguageTool Integration v0.3.3
    6: Dictionary v2.22.0

Additional information

I disabled all community plugins and it does the same thing.

I don’t see this behavior (MacOS 13.1).

Here’s the text I used:

## Heading

- [ ] Checklist
- [ ] Number two

I also tried an h3, and tried removing the blank line under the heading, tried switching to Source Mode.

Could you post an example?

I can’t seem to reproduce it either (macOS 13.2.1; Obsidian v1.1.16).

As well as a source example, could you check in the sandbox vault? Thanks.

Yes, it does work after the first H2. I just realized it happens after the second H2.

Here’s the text I’m using to test:

## First title
- [ ] checkbox
- [ ] It works here

## Second title
- [ ] but it doesn't here
- [ ] checkbox

What is the sandbox vault?

Mentioned in the debug help link above.

Help (question mark) / F1 → Sandbox vault

Still not seeing it here with that example.

Oh… that’s weird. You mean it only happens in my end? What can I do about it?

I checked in the sandbox vault and it doesn’t happen there. Just in my personal vault. Is my vault corrupted? Is it a problem of the vault or the UI?

Update: I disabled a css snippet I had running and the problem went away. It must be something I did wrong in that snippet, right?

The problem being that I was using .HyperMD-header.HyperMD-header-2.cm-line selector because I wanted to affect the H2 while in editor mode. When I take it out, the problem disappears.

Is there a better way to do it? (I am very new to obsidian)

This is my css:

/* H2 styling */
body.h2-underline h2,
body.h2-underline .HyperMD-header.HyperMD-header-2.cm-line {
	margin-bottom: 10px !important;

I don’t know Obsidian’s CSS well, but I suspect that playing with vertical margins in the editor may be likely to cause odd behavior. If I understand your snippet correctly, I’d suggest just typing a blank line after headings.

But the wizards in the Obsidian Discord’s #appearance channel know a lot more than I do, so I recommend consulting them.

1 Like

Thank you @CawlinTeffid and @ariehen for your help! We can now close this issue.

1 Like


Next time anything is acting strange, have a look at that debug help link. Not always, but a lot of the time, following those steps can get you back in a good spot.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.