Home/End when using Vim Keybindings

What I tried

I tried searching for this problem in the forum and found reference to it back in 2020, with the claim that it was fixed, but that doesn’t match my current experience.

What I’m trying to do

When using vim keybindings, I have j mapped to gj and similarly for k. This is to get it to move along lines in a logical sense, more like other text editors (than vim). However, unlike other Apps with Vim keybindings, Obsidian doesn’t seem to support moving to the beginning or end of a “logical” line. Using 0 or $ goes to the beginning/end of the “paragraph” (real, non-logical, line). From what I’ve read, in Vim you can do g0 or g$ to do it based on logical lines but I don’t remember ever having to do this in any other applications I use that have Vim keybindings. In either case, it appears Obsidian doesn’t support g0 or g$, as they do nothing.

Is there anything I can do to get home/end (0/$) working in terms of visual/logical lines as opposed to the whole “paragraph”?

Thanks