Hebrew (RTL) cursor jumping words freezes Obsidian

I have noticed for several months that if I am working in Hebrew (a rtl language), and either use ctrl-left or ctrl-right OR vim mode w or e or b, at a certain point it will freeze Obsidian, and I just have to restart the program.

Steps to reproduce

The behavior is fairly reproducible, at least in my environment. I have noticed the bug more often when using vim mode, but happens when in normal mode as well.

  1. Insert cursor in the middle of some Hebrew text. For example:

כִּי֩ כֹ֨ה אָמַ֜ר רָ֣ם וְנִשָּׂ֗א שֹׁכֵ֥ן עַד֙ וְקָד֣וֹשׁ שְׁמ֔וֹ

  1. Make cursor jump around using ctrl-left or ctrl-right or vim mode.
  2. Pretty quickly it freezes (not every time, but maybe 40% of the time).

It’s possible there are certain character combinations or factors that contribute to this, but I was unable to determine what.

Expected result

Not to freeze.


  • Operating system: Windows 10 64 bit
  • Debug info:
    Obsidian version: v1.0.3
    Installer version: v0.15.8
    Operating system: Windows 10 Pro 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 23
    Plugins enabled: 18
    1: Vimrc Support v0.7.3
    2: Footnote Shortcut v0.0.9
    3: Shortcuts extender v2.2.0
    4: Tag Wrangler v0.5.4
    5: Recent Files v1.3.3
    6: Quiet Outline v0.3.3
    7: Templater v1.14.3
    8: QuickAdd v0.5.5
    9: Citations v0.4.5
    10: Advanced Tables v0.17.3
    11: Excalidraw v1.7.25
    12: Graph Analysis v0.15.4
    13: Highlightr v1.2.2
    14: Breadcrumbs v3.6.4
    15: Pane Relief v0.4.1
    16: Dataview v0.5.47
    17: Text Snippets v0.1.2
    18: Various Complements v7.3.0

Download and reinstall Obsidian.
Use the sandbox vault in RTL mode. Post a screen recording of this happening.

I made the recommended change a week ago, and haven’t noticed the problem since. This seems to have fixed it, thanks!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.