Header suggestion is not triggered when `#` is typed

Hey @Klaas,
Thnx for clarifying.
The # doesn’t seam to have the expected behaviour on my computers (OSX v0.8.8)
Bug? I don’t know :thinking:
After typing any letter that appears in the heading the list is shown.
The |behaviour is OK and works.

Yes. Should be fixed in 0.89

1 Like

I am surprised that:

  1. you have that problem because I don’t (OSX v0.8.8)
  2. @Dor says it will be fixed, which suggests others, though not everyone, had it too.

Anyway, this is resolved.

I just realised what you describe as a “bug”: it is not. My step 3 above should have read:

instead, type # , <b>then type the 1st letter of the header</b>, which will result in a list of all the headers in that note

When I want to link in note A to a header in note B, I always have a pane with note A open next to a pane with note B showing me the header I want to link to. So, picking the 1st letter of that header is not a problem.

Quoting Licat on Discord

#bug ? link to an existing page, click # to link to a heading…nothing. type a letter that you know is in a heading…a selection appears. It used to show all headings straight from the #.

@Jeffurry Bug indeed, will be fixed in next release.

@Dor OK. It never “bugged” me, so did not strike me as a “bug”. If it gets fixed, fine.

1 Like

It would be great if the # shows all the headers of the mentioned document.
The ‘workaround’ is OK for now.
Another great thing about Obsidian: You don’t have to wait for weeks (even months) until a new version gets shipped.
Great job!

1 Like

Some screenshots from my TestVault

Just before I type the # (I do not click on the selected Transclusion Note 1)

When I type the #
Nothing happens

When I type a letter which appears in the title(s)

This is the wanted behaviour of the # in my opinion

1 Like

Hi Rik, this is a current bug and will be fixed in the next insider release, 0.8.9. Cheers! Sorry about that.

@Silver: does that fix also include auto-update for when a header title changes?

No it doesn’t I just filed a bug report on that one together with some other remarks/strange behaviour things.

How do you know it doesn’t fix the auto-update for when a header title changes?

Because I tested it:
I did block referencing with a header.
I changed the title of the header
Result: Link not changed.
Hence my comment.
Hopefully I didn’t misunderstand anything.

I think we’re talking cross-purposes.

Say in note A you have a link to header 1 in note B.
If you change the title of note B the link in note A will get updated so the link is not broken, provided you have the option set in the Preferences.

However, if you change the title of header 1, the link does NOT get updated as an auto-update. The devs are aware of this and have said it will get fixed.

Since they are fixing the other header issue you flagged in this thread, my question to Silver was if the header link auto-update issue will get fixed with the same fix for version 0.8.9.

My bad: Misunderstanding and not going back far enough in the threads. Sorry for that :frowning:

The title updates are perfectly fine.
I suppose you are referring to this setting to make that happen automatically instead of always been asked when you change a title

On the other header issue. Hope I did understand this correctly (again English is not my mothertongue)…

Suppose @Klaas is referring to the # behaviour then (?)
When I change the Header information it already shows the changes in the 0.8.8 version I am using right now.

Example (from my linked TestVault a posted in the bug report). When you type # followed by H in Bug Research - Linked mentions note it shows the changed H1 header which you can then select and is pasted correctly in the note.

@RikD: we’re still not on the same wavelength, because the issue is still present in 0.8.8, which I am using too.

If you follow these steps you’ll see what I mean.

  • In note A make a link to # header-1 in note B

  • In note A, Preview mode, click on the link. It should take you to # header-1 in note B. #header-1 will be highlighted.

  • In note B change the title of # header-1 to # header-2

  • Go to note A, Preview mode, click on the link. It will take you to note B, but not to # header-2 because the link in note A was not updated automatically when you changed the header name in note B.

The link does NOT get updated as an auto-update.

Language can be such a wall :frowning:
I did the steps your explaining
This is exactly what I wanted to say!

Have you also seen the Linked mention pane?

Even though you changed the header, the pane displays a link to note A stating [[note B#Header-1" as being the link?

I do believe this is not correct behaviour (?) and I also could interpret that this is the behaviour you were mentioning (still faulty in 0.8.8)

That’s the strange behaviour I was looking for in my bug report that I couldn’t reproduce directly. Thanks for helping me there!

When you add the text Backlink to note A under Header-2 (changed) in note B Obsidian correctly puts this phrase in the Unlinked mentions referring you could possibly backlink note A in note B by enclosing note A in [[]]

When you do that the backlink is correctly put in the Linked mention pane under note B.

Again when any changes are made to the header we come in the same ‘faulty’ behaviour explained.

Babylon issue resolved I think :wink:

@RikD: English is not my mother tongue either, so between us the tower of Babylon can easily rise on its own. Still, we managed to break it down.

And I do wish this header link issue will get resolved soon because I use it a lot in combination with transclusions.

1 Like

Not sure what the issue is. The fix is in 0.8.9 so no-one has it yet. We’ll see what it cures when it arrives.