Graph View Is Blank on linux after OS update

Steps to reproduce

I open my populated vault, and use the Ctrl + G hotkey to open the Graph View. While the tab is open, nothing appears in the Graph View.

This is reproduced in the .AppImage file in the Sandbox Vault.

Expected Result

I expected there to be at least one node, considering there are markdown files all about.

Actual Result

While the Graph View tab was open, and the sidebar was present, no nodes were populating the window.



Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: #1 SMP PREEMPT_DYNAMIC Debian 6.5.3-1kali2 (2023-10-03) 6.5.0-kali2-amd64
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0

Personal Vault

Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: #1 SMP PREEMPT_DYNAMIC Debian 6.5.3-1kali2 (2023-10-03) 6.5.0-kali2-amd64
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Things v2.1.6
Snippets enabled: 1
Restricted mode: off
Plugins installed: 22
Plugins enabled: 22
1: Advanced Tables v0.19.1
2: Dataview v0.5.59
3: Excalidraw v1.9.20
4: Calendar v1.5.10
5: Templater v1.16.3
6: Periodic Notes v0.0.17
7: Banners v1.3.3
8: Emoji Shortcodes v2.2.0
9: Auto Note Mover v1.2.0
10: Advanced Slides v1.20.0
11: Better Word Count v0.10.0
12: YouHaveBeenStaring v1.2.2
13: Obsidian jTab v1.2.2
14: CardBoard v0.7.2
15: Heatmap Calendar v0.6.0
16: Better footnote v1.0.1
17: HTML Reader v1.0.10
18: Obsidian Enhancing Export v1.9.1
19: Footnote Shortcut v0.1.3
20: Obsidian Charts v3.7.2
21: Flashcards (Fixed) v1.6.5a
22: Day Planner v0.10.1

Additional information

Sandbox Screenshot


I did a massive update of my system, so maybe I am missing a library?
Unsure, thought I’d ask before I go digging around.

maybe is your system problem, you can try to run Obsidian with hardware accell off (System>about)

Alright so, the graph view definitely showed up, but with >6000 notes it was maxing my CPU out.

Is there anything that I can do to put the load back on the GPU?

I’m also having this problem, and disabling hardware acceleration fixes it but causes my laptop fans to turn into jet engines.

If I do manage to view the graph with hardware acceleration on (usually relaunching obsidian means i can see the graph), the nodes themselves aren’t rendered, only edges between them.

I’m on Fedora on a Framework 13 (Intel iGPU therefore)

Obsidian version: v1.4.16
Installer version: v1.4.13
Operating system: #1 SMP PREEMPT_DYNAMIC Fri Oct 6 19:02:35 UTC 2023 6.5.6-200.fc38.x86_64
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 2
Plugins enabled: 2
1: Omnisearch v1.18.1
2: Folder Index v1.0.21

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

1 Like

If this was the result of system update, I hope it is fixed upstream.

Will the dev team see this entry? or do i need to bug report somewhere else?

I just ran a system update and it is now fixed. I’ve included what was updated but I can’t see anything particularly suspicious other than maybe the kernel itself having a bad interaction with intel igpus.

 kernel                        x86_64 6.5.8-200.fc38    updates           148 k
 kernel-core                   x86_64 6.5.8-200.fc38    updates            16 M
 kernel-modules                x86_64 6.5.8-200.fc38    updates            57 M
 kernel-modules-core           x86_64 6.5.8-200.fc38    updates            31 M
 kernel-modules-extra          x86_64 6.5.8-200.fc38    updates           2.6 M
 aspnetcore-runtime-6.0        x86_64 6.0.23-1.fc38     updates           6.9 M
 aspnetcore-targeting-pack-6.0 x86_64 6.0.23-1.fc38     updates           1.4 M
 clang15-devel                 x86_64 15.0.7-5.fc38     updates           2.3 M
 clang15-libs                  x86_64 15.0.7-5.fc38     updates            21 M
 clang15-resource-filesystem   x86_64 15.0.7-5.fc38     updates            11 k
 container-selinux             noarch 2:2.224.0-1.fc38  updates            55 k
 crun                          x86_64 1.10-1.fc38       updates           215 k
 cups-filters                  x86_64 1:2.0.0-1.fc38    updates           217 k
 dotnet                        x86_64 6.0.123-1.fc38    updates           9.6 k
 dotnet-apphost-pack-6.0       x86_64 6.0.23-1.fc38     updates           3.9 M
 dotnet-host                   x86_64 7.0.12-1.fc38     updates           197 k
 dotnet-hostfxr-6.0            x86_64 6.0.23-1.fc38     updates           163 k
 dotnet-runtime-6.0            x86_64 6.0.23-1.fc38     updates            23 M
 dotnet-sdk-6.0                x86_64 6.0.123-1.fc38    updates            77 M
 dotnet-targeting-pack-6.0     x86_64 6.0.23-1.fc38     updates           2.2 M
 dotnet-templates-6.0          x86_64 6.0.123-1.fc38    updates           2.5 M
 fzf                           x86_64 0.43.0-1.fc38     updates           1.3 M
 gdb                           x86_64 13.2-6.fc38       updates           134 k
 gdb-headless                  x86_64 13.2-6.fc38       updates           4.7 M
 glibc                         i686   2.37-12.fc38      updates           1.9 M
 glibc                         x86_64 2.37-12.fc38      updates           2.1 M
 glibc-all-langpacks           x86_64 2.37-12.fc38      updates            18 M
 glibc-common                  x86_64 2.37-12.fc38      updates           319 k
 glibc-devel                   x86_64 2.37-12.fc38      updates            53 k
 glibc-gconv-extra             i686   2.37-12.fc38      updates           1.7 M
 glibc-gconv-extra             x86_64 2.37-12.fc38      updates           1.6 M
 glibc-headers-x86             noarch 2.37-12.fc38      updates           534 k
 glibc-langpack-en             x86_64 2.37-12.fc38      updates           635 k
 gnuradio                      x86_64
                                                                          3.7 M
 google-chrome-stable          x86_64 118.0.5993.117-1  google-chrome     101 M
 httpd                         x86_64 2.4.58-1.fc38     updates            50 k
 httpd-core                    x86_64 2.4.58-1.fc38     updates           1.4 M
 httpd-filesystem              noarch 2.4.58-1.fc38     updates            12 k
 httpd-tools                   x86_64 2.4.58-1.fc38     updates            80 k
 ibus-typing-booster           noarch 2.24.4-1.fc38     updates           1.2 M
 iptables-libs                 x86_64 1.8.9-4.fc38.1    updates           414 k
 iptables-nft                  x86_64 1.8.9-4.fc38.1    updates           192 k
 libbytesize                   x86_64 2.10-1.fc38       updates            48 k
 libnsl                        i686   2.37-12.fc38      updates            85 k
 libnsl                        x86_64 2.37-12.fc38      updates            80 k
 libppd                        x86_64 1:2.0.0-1.fc38    updates           265 k
 librepo                       x86_64 1.17.0-1.fc38     updates            96 k
 mod_http2                     x86_64 2.0.25-1.fc38     updates           161 k
 mod_lua                       x86_64 2.4.58-1.fc38     updates            58 k
 mysql-community-client        x86_64 8.0.35-1.el9      mysql80-community 3.5 M
                               x86_64 8.0.35-1.el9      mysql80-community 1.4 M
 mysql-community-common        x86_64 8.0.35-1.el9      mysql80-community 557 k
                               x86_64 8.0.35-1.el9      mysql80-community 2.3 M
 mysql-community-libs          x86_64 8.0.35-1.el9      mysql80-community 1.4 M
 mysql-community-server        x86_64 8.0.35-1.el9      mysql80-community  49 M
 mysql80-community-release     noarch el9-5             mysql80-community  13 k
                               x86_64 7.0.112-1.fc38    updates           1.3 M
 oniguruma                     x86_64 6.9.9-1.fc38      updates           219 k
 pipewire                      i686   0.3.83-2.fc38     updates           113 k
 pipewire                      x86_64 0.3.83-2.fc38     updates           112 k
 pipewire-alsa                 i686   0.3.83-2.fc38     updates            64 k
 pipewire-alsa                 x86_64 0.3.83-2.fc38     updates            64 k
 pipewire-gstreamer            x86_64 0.3.83-2.fc38     updates            64 k
                               x86_64 0.3.83-2.fc38     updates            16 k
                               x86_64 0.3.83-2.fc38     updates           140 k
 pipewire-libs                 i686   0.3.83-2.fc38     updates           1.8 M
 pipewire-libs                 x86_64 0.3.83-2.fc38     updates           1.8 M
 pipewire-pulseaudio           x86_64 0.3.83-2.fc38     updates           174 k
 pipewire-utils                x86_64 0.3.83-2.fc38     updates           349 k
 python3-bytesize              x86_64 2.10-1.fc38       updates            26 k
 python3-gnuradio              x86_64
                                                                          4.1 M
 python3-unbound               x86_64 1.18.0-2.fc38     updates           116 k
 python3-urllib3               noarch 1.26.18-1.fc38    updates           258 k
 python3-urllib3+socks         noarch 1.26.18-1.fc38    updates           9.6 k
 qadwaitadecorations-qt5       x86_64 0.1.2-5.fc38      updates            56 k
 qadwaitadecorations-qt6       x86_64 0.1.2-5.fc38      updates            63 k
 slirp4netns                   x86_64 1.2.2-1.fc38      updates            47 k
 unbound-anchor                x86_64 1.18.0-2.fc38     updates            35 k
 unbound-libs                  x86_64 1.18.0-2.fc38     updates           534 k
 vim-common                    x86_64 2:9.0.2048-1.fc38 updates           7.7 M
 vim-data                      noarch 2:9.0.2048-1.fc38 updates            23 k
 vim-filesystem                noarch 2:9.0.2048-1.fc38 updates            18 k
 vim-minimal                   x86_64 2:9.0.2048-1.fc38 updates           805 k
 virtualbox-guest-additions    x86_64 7.0.12-1.fc38     updates           612 k
 volk                          x86_64 3.0.0-20231020.0.gitfdc87b1f.fc38
                                                                          492 k
 volk-devel                    x86_64 3.0.0-20231020.0.gitfdc87b1f.fc38
                                                                          153 k
 wine                          x86_64 8.18-1.fc38       updates            11 k
 wine-alsa                     i686   8.18-1.fc38       updates            85 k
 wine-alsa                     x86_64 8.18-1.fc38       updates            87 k
 wine-arial-fonts              noarch 8.18-1.fc38       updates            99 k
 wine-cms                      i686   8.18-1.fc38       updates            95 k
 wine-cms                      x86_64 8.18-1.fc38       updates           103 k
 wine-common                   noarch 8.18-1.fc38       updates            69 k
 wine-core                     i686   8.18-1.fc38       updates            87 M
 wine-core                     x86_64 8.18-1.fc38       updates            92 M
 wine-courier-fonts            noarch 8.18-1.fc38       updates            88 k
 wine-desktop                  noarch 8.18-1.fc38       updates           113 k
 wine-filesystem               noarch 8.18-1.fc38       updates           1.7 M
 wine-fixedsys-fonts           noarch 8.18-1.fc38       updates            23 k
 wine-fonts                    noarch 8.18-1.fc38       updates            10 k
 wine-ldap                     i686   8.18-1.fc38       updates           716 k
 wine-ldap                     x86_64 8.18-1.fc38       updates           761 k
 wine-marlett-fonts            noarch 8.18-1.fc38       updates            22 k
 wine-ms-sans-serif-fonts      noarch 8.18-1.fc38       updates           1.6 M
 wine-opencl                   i686   8.18-1.fc38       updates            70 k
 wine-opencl                   x86_64 8.18-1.fc38       updates            75 k
 wine-pulseaudio               i686   8.18-1.fc38       updates            62 k
 wine-pulseaudio               x86_64 8.18-1.fc38       updates            63 k
 wine-small-fonts              noarch 8.18-1.fc38       updates            25 k
 wine-symbol-fonts             noarch 8.18-1.fc38       updates            36 k
 wine-system-fonts             noarch 8.18-1.fc38       updates            29 k
 wine-systemd                  noarch 8.18-1.fc38       updates            11 k
 wine-tahoma-fonts             noarch 8.18-1.fc38       updates           118 k
 wine-times-new-roman-fonts    noarch 8.18-1.fc38       updates           106 k
 wine-twain                    i686   8.18-1.fc38       updates           136 k
 wine-twain                    x86_64 8.18-1.fc38       updates           143 k
 wine-webdings-fonts           noarch 8.18-1.fc38       updates            21 k
 wine-wingdings-fonts          noarch 8.18-1.fc38       updates            23 k
 x264-libs                     x86_64 0.164-10.20231001git31e19f92.fc38
                                                                          701 k
 xen-libs                      x86_64 4.17.2-4.fc38     updates           643 k
 xen-licenses                  x86_64 4.17.2-4.fc38     updates            55 k
 xxd                           x86_64 2:9.0.2048-1.fc38 updates            36 k

Well I’ll immediately take that back. It worked once then stopped again

Same problem here on Arch Linux after updating from mesa 23.3.1 to mesa 23.3.2.

Deleting ~/.config/obsidian/GPUCache fixed it.

Obsidian version: v1.5.3
Installer version: v1.5.3
Operating system: #1 SMP PREEMPT_DYNAMIC Thu, 21 Dec 2023 19:01:01 +0000 6.6.8-arch1-1
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Dataview v0.5.64

Oh for sure. Whitenoise is on the Obsidian Team and they’re not very large. Used to be just 2 people but it appears to be growing. From the start the devs (esp Silver) appear to have been pretty actively a part of this forum.
(thank you guys! I don’t always like the judgements but I appreciate them and your careful consideration and participation in all the things :heart: )

Oh, I forgot, I meant to say that I’m seeing this on Xubuntu 22.04.3 when I have hardware acceleration enabled on a Thinkpad P16 (see hardware report attached) (12.5 KB)

For now it’s fine running without acceleration but thought the data may be helpful. Thanks again!

Still experiencing this, now on Fedora 39. Runnning without hardware accel causes my laptop fans to take off

Just tuning in to confirm I also lost graph view after a system upgrade on Kali on an OMEN 15 with a GTX 1050
Coincidentally, it was also when I OBS stopped being able to record with error “NVENC function not implemented”
My best guess is some NVIDIA driver update messed up
Deleting the GPUCache folder as Piped suggested seems to have fixed it for me

I’ve found success in using the Flatpak instead of the AppImage, for those that stumble across this post

Ok, revised again because clearing the cache helped again but it acts funky and doesn’t seem to keep up when I adjust sliders. Sometimes the sliders just start hopping around all over the place if I make an adjustment or try to massage the graph by moving sliders around.

Looks like I installed via snap and am currently at 1.5.8

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.