Graph menu spams

Hi,

Im new to Obsidian and absolutely loving it so far. I’ve run into a problem though, and after a few hours trying to fix it, i figured i better ask for some help.

What I’m trying to do

Add groups/collors to the graph view. This was working, but now the menu flickers/spasms. Creating a group needs a lot of clicking on ‘new group.’ When selecting the line to add the filter the box outline flickers white/gray, basically selecting and unselecting the line.

I can sometimes enter 2 or 3 characters before it unselects, but mostly i cant. Trying to reselect and add characters it selects all text, and deletes all my previous imputs. It takes about 15-30 mouseclicks to even select it for a brief window of time.

The weird thing is, it used to work. On my phone it also works fine.

Using: desktop app with dataview, templater and tagwrangler plug ins stored on Google Drive (with the folder available offline)

Things I have tried

  • Search the internet for solutions
    • i found deleting a file in the GPU cache file in the .config/obsidian folder might help, but i cant locate this folder.
  • I tried deleting the graph.json (just because i thought it might be connected) After this the graph itself worked again. (before this i had both the menu glitch and the graph would dissapear after building)
  • i tried opening the sandbox Vault → graph works fine here
  • Opening a back up of the same vault: same problem
  • Reeinstaling the app
  • tied deleting 3 templates using several tp.date commands as this created several ‘non existing notes’ (though i now filter those out)

Obsidian graph glitch
Obsidian graph cant filter
Solutions: see above

Any help would be greatly apreciated

Well, this magicaly solved itself