Getting a total plugin setup error when I open my vault

Things I have tried

Searched for a solution in Help category. Tried using the console to figure out the problem.

What I’m trying to do

When I open my vault, I am getting the following error notification. I looked at the console, but am not sure how to fix it. I think it has really slowed down my vault

Total plugin setup: 2,405ms
nlp: 598ms
obsidian-excalidraw-plugin: 343ms
dbfolder: 131ms
cm-editor-syntax-highlight-obsidian: 70ms
breadcrumbs: 65ms
dataview: 64ms
obsidian-daily-stats: 63ms
obsidian-mind-map: 59ms
obsidian-local-images: 55ms
media-extended: 49ms
scambier.obsidian-omnisearch: 48ms
obsidian-linter: 44ms
table-editor-obsidian: 43ms
obsidian-kanban: 41ms
obsidian-enhancing-mindmap: 40ms
obsidian-admonition: 39ms

I am getting the following error notification

What’s the error message?

Also, are your plugins up-to-date? Omnisearch’s id is just “omnisearch” since it’s no longer in beta, you should reinstall it.

Thank you for your help. I was able to figure it out.