Front matter doesn't show anymore in preview

Steps to reproduce

  1. Enable ‘Show frontmatter’ in the ‘Editor’ settings.
  2. Use the default light theme and disable custom CSS.
  3. Go to Preview mode with a note.
  4. The front matter doesn’t show.

Expected result

I expect the front matter to show like it did with 0.9.20 and earlier.

Actual result

See above.

Example note

Create a note with:

title: "Where is the front matter?"

Hello there.

In Editor mode, this note shows as:

In preview mode, it shows as:


  • Operating system: Windows 7 64-bit.
  • Obsidian version: 0.9.21.

I think this is intended - there are some CSS-Themes which give you a button to reveal front matter (Minimal Theme by kepano does this I think)

1 Like

This might be, but then the ‘Show frontmatter’ option is broken because with that setting enabled and Obsidian’s default theme, I don’t see the front matter.

Ah I see. Never mind then - I was not aware of this option!

Caused by the same issue as this one: Left margin (or padding) in preview mode changed/broken

Will be fixed as soon as we ship the next patch release.

1 Like