[FR] Iframes don’t render on iOS

Steps to reproduce

Open new note on Mac version of the app.
Add an iframe for either Trello or OmniFocus for the web.

Enter preview mode.

Log in when prompted by the iframe embeds.

Go to an iOS device and find the note with iframes.

Ente preview mode. Iframes appear as blank white space instead of embeds.

Expected result

Same results that I did on Mac.

Actual result

Blank white space.

Environment

  • Operating system: macOS
  • Obsidian version: 1.0.4

Additional information

1 Like

I don’t see any images

What is the proper way to upload images on Discourse? I’m on the mobile app and when I pressed the upload button and selected the screenshots from the camera roll, it just put some markdown in the text field linking to the images but I’m not sure it actually uploaded them anywhere?

Fixed! It was just a line break issue.

It looks like there’s some issue with CORS on mobile.

1 Like

@WhiteNoise Sorry, I didn’t fix the iframe issue—just the OP’s screenshots :wink:

This is still unresolved!

1 Like

I am gonna move this mobile feature requests

2 Likes

Perhaps - if technically possible - Mobile could receive in a future update the same patch …

You can now use <iframe> to embed even more sites that previously wouldn’t show. This is done by patching the Content-Security-Policy header containing frame-ancestors that some websites use to prevent embedding.

… that the Desktop Obsidian Release v0.11.1 received in February.

PS: I am on Obsidian Mobile Android 1.0.4
¨Includes all new functionality and bug fixes of Obsidian Desktop v0.12.12"
With inherent “Mobile” limitations I guess.