Forum Help: Unable to Edit Reply (Basic Permission) + App Connection Error

Unable to Edit Reply

I went to edit my reply here, and there is no Edit button. I researched and checked that it is supposed to appear as a pencil icon. Looking over the trust levels here (this link came from Basic badge), it appears that I’m supposed to have the ability to edit my own reply–at least within this couple of hours, I’d think.

I tried to use the “e” keyboard shortcut suggested in the menu, but it didn’t do anything anywhere that I tried it.

Any suggestions?

App Connection Error

I also downloaded the Discourse iPad app and tried repeatedly to connect to this forum in case the interface made it easier to edit posts, but only ever got this error message when it tried to open a login popup window–just FYI, I guess!


The software powering this discussion forum encountered an unexpected problem. We apologize for the inconvenience.

Detailed information about the error was logged, and an automatic notification generated. We’ll take a look at it.

No further action is necessary. However, if the error condition persists, you can provide additional detail, including steps to reproduce the error, by posting a discussion topic in the site’s feedback category.

Unable to Edit Reply Issue: Update

Weirdly, I cannot edit my above post, nor the original post I mentioned, but the edit button does appear on my latest post? So confused…

Editing of posts was time-restricted because of a large spam attack that the forum got last year. Bots would wait an interval and then edit their posts to include spam links, and it was very hard to detect for the small mod team.

So you can append to a post by replying, and if there is a major reason you need something redacted or removed, you can reach out to a moderator for help.

As for the iPad problem, I’m not sure why. I never tried the app. I only ever logged into the forum through Safari on iPad. Have you tried that yet? If you still have the problem, maybe it’s a VPN/network issue? Otherwise maybe there are some clues in that “automatic notification”. (I’m a moderator on break, so I can’t check if that notification went to this forum, or to Discourse itself.)


I use DiscourseHub to engage with the forum on iPhone and iPad.

Not sure what’s causing this issue. Maybe a VPN, like Rigmarole suggests. Make sure you’re using the right address when you add the forum to the app:

1 Like

Oh, OK! I was just confused because I tried to edit it right away and couldn’t, but then I could edit this one other random post for quite a while and I couldn’t figure out the discrepancy…oh well! The post seemed to indicate 24 hours but was not explicit. Could somebody update documentation (maybe the FAQ–which, BTW, has a broken link to a forum feature request area that should probably point to Meta instead) to make it clearer how it’s supposed to work?

I’m fine with just replying to myself, but I’ve been in forums where they frown on too much of that.

For the iPad app thing, I’ll put my comments in a reply to ryanjamurphy’s post.

1 Like

Discourse iPad App Thing

Per @rigmarole’s comment, I can log in through Safari just fine, but the point at the time was to see if the app had a different UI for editing posts so :woman_shrugging:.

Also, I don’t have a VPN. I double-checked the address and it’s still giving me the same error, so I think I’m just not going to worry about it.

It does work on my iPhone, and if nobody else is having the issue I’m not worried about it!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.