Focus jumps in the note unexpecdatly

Steps to reproduce

In a note, I’m moving my text cursor to a paragraph (either with the keyboard or the mouse) and it jumps to another one. See the Loom video here:

Expected result

Actual result


Obsidian version: v1.2.1
Installer version: v1.1.9
Operating system: Darwin Kernel Version 22.4.0: Mon Mar 6 21:01:02 PST 2023; root:xnu-8796.101.5~3/RELEASE_ARM64_T8112 22.4.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: AnuPpuccin v1.4.1
Snippets enabled: 3
Restricted mode: off
Plugins installed: 35
Plugins enabled: 30
1: Advanced Tables v0.18.1
2: Calendar v1.5.10
3: Dataview v0.5.55
4: Excalidraw v1.8.21
5: Footnote Shortcut v0.0.9
6: Hover Editor v0.11.9
7: Minimal Theme Settings v6.3.1
8: Natural Language Dates v0.6.1
9: Note Refactor v1.7.1
10: Obsidian42 - Strange New Worlds v1.1.4
11: Periodic Notes v0.0.17
12: QuickAdd v0.17.1
13: Readwise Official v2.0.1
14: Review v1.6.4
15: RTL Support v1.1.1
16: Simple Embeds v1.14.1
17: Tasks v2.0.1
18: Style Settings v1.0.3
19: Templater v1.16.0
20: Todoist Plugin v1.10.1
21: Tracker v1.10.9
22: Typewriter Scroll v0.2.2
23: Workspaces Plus v0.3.3
24: Advanced Mobile Toolbar v1.8.0
25: Customizable Page Header and Title Bar v4.6.2
26: Omnisearch v1.13.0
27: MetaEdit v1.8.0
28: Kanban v1.5.2
29: Zotero Integration v2.3.8
30: Remember cursor position v1.0.7

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Does this happen in the Sandbox vault? See →