Files Won't Save EPERM Error

I am getting this error whenever I try to update any of my markdown files. image.
Any ideas would be extremely helpful! Thank you!

Things I have tried

  • Restarting Computer
  • Deleting .config/Obisidian folder
  • Resinstalling Obsidian
  • Deleting Vault and Reinstating Vault

What I’m trying to do

1 Like

Are you sure obsidian has write access to that folder?

Hey the same problem occurs to me to. @WhiteNoise what do you mean by that, doesn’t obsidian have write access to any folder?

I don’t know what your system configuration is.

That must be the problem. I didn’t have an issue until I updated to v0.11.9. I have admin permissions on a Windows 10 PC.

Does it happen in the help vault?

If I understand your question correctly yes. I initially set this up as a vault on an older version of Obsidian. I had no issues until I installed a fresh copy of Obsidian (the update feature wasn’t letting me update for some reason) and I tried using that same vault.

No what I asked if this error happens in the included help vault not in this vault you created.

Whare is your vault stored exactly? what’s the path?

Also what happens if you create another vault somewhere else?

why is that?

Okay, so I have no issues editing and saving the help vault. My vault lives in my Documents folder, and when I try to create another vault within the Documents folder, it doesn’t work. It seems with this latest installation I’m having trouble getting permissions to write to my Documents folder.

I’m not sure why it wasn’t letting me update. My assumption was that the version I was on before was too old. I hadn’t updated in a while.

What if you create your vault somewhere else, like C:\Test?

Are your documents on one drive or some other sync platform?

Do you use symbolic links?

When I create a vault on C:\Test I have no issues with it. I don’t use symbolic links here (although I do have some mapped network drives elsewhere on my computer) and I’m not syncing this folder with OneDrive, although I am pushing it to a git repository occasionally.

Honestly, I’m at least happy to know that I can just move these files to my C:\ and then get it working again.

I think you ran into some sort of permission issue. I don’t know if there is something odd in your documents folder or if there is something odd with obsidian installation. You can try to uninstall obsidian and also delete

1 Like

Excellent! Thank you very much, for the help!

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.