Files can't be opened - error properties of undefined


I opened my Obsidian after a week (holidays), and I was surprised to see that my notes couldn’t be opened.

When I right-click on a note and select open in new tab, I see an error saying:

Cannot read properties of undefined (reading 'file')

I changed nothing to my Obsidian or configuration or plug-ins… So I don’t know where to look. Can someone help me? Does someone have the same problem?

Thanks, and happy new year,


Try with no plugins (Settings>Community Plugins>Restricted mode ON).

1 Like

Hi @ariehen ,

Thanks for your reply.

I tested with no plugins, and it worked. So I dived a little to see that several plugins needed to be upgraded. It worked. Thanks a lot. I haven’t thought of that.



1 Like

No problem. :+1:t3:

If things are acting weird it’s good to try in Restricted mode. If that works, turn Restricted mode off and toggle off all the plugins individually. Check for updates. Turn them on in batches to find the culprit.

You are totally right. Next time I will be more cautious and will follow those steps.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.