File access weirdness in a VM

Steps to reproduce

Install Obsidian into a Linux Mint 19 VM (possibly other versions) and try to create a vault in a shared folder presented by VirtualBox.

Expected result

I expect the vault to be created.

Actual result

I received a permissions error, and fouled permissions on existing folder, or the vault folder; the user and group changed to nobody:nogroup.


  • Operating system: Linux Mint 19
  • Obsidian version: 0.9.17

Additional information

My apologies if this has already been reported; I did look and cannot find a similar problem. I installed Obsidian 0.9.17 into a Linux Mint 19 VM hosted by VirtualBox 6.1.4. A folder on the host system (Mac) is used for data storage for the VM; this is not a new VM, the storage and permissions have always been fine. From the VM’s point of view, all files in the storage have the user and group of root:vboxsf. This is normal. When I tried to create the vault on this existing shared directory, inside of an existing directory called data, I received an error about not having permission. When I then looked at the ‘data’ directory, the user and group appeared as nobody:nogroup. On the surface, it looked like Obsidian did something to the permissions. I could not access this folder because of the new ownership. However, when I rebooted the VM, the ‘data’ folder showed normal ownership of root:vboxsf. So it seems that Obsidian somehow confuses the VirtualBox tools (called Guest Additions). If I create the vault on the VM’s boot drive, it’s fine. Today, from a vault on the boot drive, I tried exporting a pdf of a test note into the shared ‘data’ folder. It created the file, and the file ownership was nobody:nogroup, thus leaving it inaccessible So, I cannot use the host storage, which is where I want the vault.