Fcitx input will missing some charactors

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

open blank document
input something
specificly type very fast

Expected result

Actual result

Environment

  • Operating system:
  • Debug info:
    os: opensuse
    version: v0.14.5 (flatpak)
    input method: fcitx

Additional information

post a screen recording of this happening in the help vault using Obsidian download from our website.

I have recorded a video, but how can I post it here

attach a link.

Make sure you use obsidian from our website (no flatpack), use the help/sandbox vault and attach the debug info requested.

Does it happen in source mode?
Does it happen here https://codemirror.net/6/ in chrome?

it still happens in source mode, and works fine in CodeMirror 6

what does the command “show debug info report”? are you using the appimage from obsidian?

It seams fine in appimage, and not works in flatpak

This is appimage debug info

SYSTEM INFO:
	Obsidian version: v0.14.5
	Installer version: v0.14.5
	Operating system: #1 SMP PREEMPT Sat Apr 9 06:30:15 UTC 2022 (b49cf22) 5.17.2-1-default
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: none
	Snippets enabled: 0
	Safe mode: off
	Plugins installed: 9
	Plugins enabled: 9
		1: Kanban
		2: Dataview
		3: Advanced Tables
		4: Calendar
		5: Excalidraw
		6: QuickAdd
		7: Mind Map
		8: Pandoc Plugin
		9: Markdown Table Editor

RECOMMENDATIONS:
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

We don’t provide support for the flatpak. It is packed by a third party. Contact the author of the flatpak.

It looks like other flatpaks add a permission for this:

I’ve added this to the latest build:

Can you run flatpak update and restart Obsidian to see if it improves input method support?

It seems to work now, I will try if that bug repeat.