Failed to save file EACESS error, nextcloud

Hi there.

What I’m trying to do

So I am running Obsidian on Macbook, and I have the local folder synced via Nextcloud.
Every now and then I get the following error:

“Failed to save: file name. EACCESS permission denied …”

Pasting also from log:

“Error: EACCES: permission denied, open [file name]
(anonymous) @ app.js:1”

Things I have tried

I’ve looked at the permissions, and everything seems to be fine. Including the enclosing folders. The thing is that when I run it locally everything works fine. I am also running another vault that is connected to a nextcloud on a different server. That also works fine - and I never got this error there. I checked settings on both Obsidian vaults and Nextclouds and they are identical.
I’m running out of ideas. Could there be something with the server access or file permissions there? Or nextcloud?

Again, this Obsidian vault mostly runs fine - I get this error from time to time only. And it seems to be pretty random, sometimes at the start of making a note, sometimes in the middle of it. When the error pops up, Obsidian makes a conflicted copy.

Any help would be appreciated.
Thanks.

I don’t have any insight, but have you searched the forum for any of those terms/phrases?

I have, and tried to change permissions and some other tips people gave, but it doesn’t work for me. It’s not a problem locally, it online occurs when I’m connected to the internet.

Hmm. Have you checked NextCloud-specific forums etc?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.