Extra backtick when used as dead key

In my current setup I use dead keys to type accented letters. To enable a dead key, I use option (⌥) as modifier. So if I want to type “á”, I press in sequence:

  1. ⌥e this results in an acute accent ´ which is underlined indicating it’s treated as dead key and waiting for the next character
  2. a which combines with ´ and makes “á”.

Every dead key is associated to a different regular key, e.g.:

  • ´ → e
  • ¨ → u
  • ` → `

I experience an issue with the backtick. I guess it depends on the fact that the backtick is automatically doubled, as it’s treated as other “surrounding” delimiters like quotes or brackets. Steps to reproduce below.

I’m up to date with the latest obsidian version. This was not happening in earlier version, but I don’t know when it started.

Steps to reproduce

Scenario 1

Let’s say I want to type “Lui è”.

  1. Type "Lui "
  2. Press ⌥`
  3. Press e

Scenario 2
Let’s say I want to type “è” at the beginning of a line.

  1. Press ⌥`
  2. Press e

Expected result

Scenario 1
Lui è

Scenario 2

Actual result

Scenario 1
Lui è`

Scenario 2

The double backtick (``) appears in Scenario 1 > Step 2 and Scenario 2 > Step 1. In both cases one of the two backticks is underlined so it’s recognized as a dead key and in both cases the end result is wrong. However the position of the extra backtick is different.


  • Operating system

macOS 12.1

  • Debug info:

Obsidian version: v0.13.19
Installer version: v0.12.12
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: on


Additional information

Screenshot of Scenario 1 > Step 2 in the help vault.

Schermata 2022-01-11 alle 19.24.10

Disable autopair markdown symbols.

this has been asked other times. Please, search before posting.