External Links Opening in Chromium

Any external URLs in Obsidian open in Chromium by default, even though I confirmed that Firefox is my default browser.

I’d like to open links in my default browser.

Things I have tried

I looked through Obsidian’s settings and I don’t see anything that would let me set a different browser to default to. I also searched this help forum for “default browser” and see at least one other Ubuntu user dealing with this issue, but no solutions:

Just to keep me on my toes, that user says their instance is opening links in Firefox and their default browser is Brave.

I also searched the help pages (which also opened in Chromium, not Firefox) for “browser” (nothing); “external links” (Markdown instructions, but nothing about designating a browser), “default” (nothing relevant)

What I’m trying to do

When I link to a web page in a note, I want to come back and use that link later.

Right now any external links are opening in Chromium. To open in my default browser (Firefox), I have to copy the URL and paste it.


Check help resources for Ubuntu. I vaguely remember seeing rare inconsistent treatment of default browser when I was on Linux (before I used Obsidian), possibly having to do with multiple ways of setting defaults.

Did you manage to solve this? I’m stuck with the same issue here :frowning:

This seems to be related to the snap packages, as both the appimage and .deb versions are opening external links using the correct browser.

1 Like

Can we fix this please? Opening external links is a trash experience under this bug


Created an account to vote on this issue being fixed. I want to open links in Chrome, but Obsidian always opens in Firefox despite my OS (Ubuntu 22.04.6 LTS) default browser being set to Chrome. No other applications exhibit this behavior except Obsidian.

I tried using the following community plugin which will force Chrome to launch, but sadly cannot get it to use the correct profile:

Upon further investigation, I was able to get Obsidian to launch Chrome by selecting a different default browser then re-selecting Chrome.

Unfortunately, Obsidian always launches a new Chrome process instead of using the currently running one, which results in the desired profile not being used. So you get a ‘blank’ browser profile, which doesn’t have any of your bookmarks/extensions/history and is basically useless.

Check this pstree output, which shows 2 trees of Chrome, the second one being opened by Obsidian:

        │         ├─chrome─┬─2*[cat]
        │         │        ├─chrome───chrome─┬─chrome
        │         │        │                 └─10*[{chrome}]
        │         │        ├─chrome─┬─chrome─┬─chrome───4*[{chrome}]
        │         │        │        │        ├─4*[chrome───15*[{chrome}]]
        │         │        │        │        ├─chrome───20*[{chrome}]
        │         │        │        │        ├─2*[chrome───31*[{chrome}]]
        │         │        │        │        ├─2*[chrome───16*[{chrome}]]
        │         │        │        │        ├─2*[chrome───7*[{chrome}]]
        │         │        │        │        ├─9*[chrome───29*[{chrome}]]
        │         │        │        │        ├─3*[chrome───28*[{chrome}]]
        │         │        │        │        ├─4*[chrome───30*[{chrome}]]
        │         │        │        │        ├─chrome───21*[{chrome}]
        │         │        │        │        ├─chrome───23*[{chrome}]
        │         │        │        │        └─chrome───34*[{chrome}]
        │         │        │        └─nacl_helper
        │         │        ├─chrome───10*[{chrome}]
        │         │        ├─chrome───6*[{chrome}]
        │         │        └─34*[{chrome}]
        │         ├─chrome─┬─2*[cat]
        │         │        ├─chrome───chrome─┬─chrome
        │         │        │                 └─7*[{chrome}]
        │         │        ├─chrome─┬─chrome─┬─chrome───5*[{chrome}]
        │         │        │        │        ├─chrome───9*[{chrome}]
        │         │        │        │        └─chrome───7*[{chrome}]
        │         │        │        └─nacl_helper
        │         │        ├─chrome───9*[{chrome}]
        │         │        └─35*[{chrome}]
1 Like

Just wanted to state that I am having the same issue as acc3d, with Obsidian opening new, blank browser profile processes each time I click on a hyperlink. Currently on Ubuntu 22.04.2 LTS and Obsidian v1.2.8 is installed via snap.

I was having same issue, ubuntu 22.04 desktop.

I uninstalled with snap and installed with the .deb option. Works like it’s supposed to now.


Had the same issue as @acc3d, just with Vivaldi instead of Chromium.
As for @jackreid, switching from Ubuntu 22.04’s snap to deb fixed it.

1 Like

I’ve been experiencing this issue on Kubuntu 22.04 LTS, using the snap package.

I found this Snapcraft thread and after investigation, I figured out that Obsidian always opens the registered browser just before my actual default.

My Default browser is currently Vivaldi, but links in Obsidian opens in Microsoft Edge .
Running gio mime x-scheme-handler/https results in:

Default application for “x-scheme-handler/https”: vivaldi-stable.desktop
Registered applications:
        microsoft-edge.desktop  # Used by Obsidian
        vivaldi-stable.desktop  # Default

Changing it to Google Chrome (with gio mime x-scheme-handler/https google-chrome.desktop) makes it open Vivaldi, since the order changed and Vivaldi is just before Chrome in the list:

Default application for “x-scheme-handler/https”: google-chrome.desktop
Registered applications:
        vivaldi-stable.desktop  # Used by Obsidian
        google-chrome.desktop  # Default

Could this be because the code references the wrong index? (i.e. Arrray starts at 0, not 1)

Weirdly enough tho, it launches a completely different instance of Vivaldi that doesn’t have my browser profile, extensions, settings, etc. :thinking:

In the meantime, I’ll install the deb version.
Hope this is helpful for debugging!

Hi there,

Ubuntu 20.4 and it opens any external link in a blank stance of my browser, with a whole new profile under obsidian window.

I tried already with no change to install the deb.

Checked before it the default browser on the system was ok…

I can confirm this is happening to me as well, using the Obsidian snap and Vivaldi browser

Managed to get a bit more info.

I launched obsidian from the command line so that I could watch the terminal output when I tried to open a link. Here’s what I see when I click on the link:

Opening URL: https://google.com/
cat: standard output: Bad file descriptor
[12258:12258:0905/175038.155830:ERROR:chrome_browser_cloud_management_controller.cc(162)] Cloud management controller initialization aborted as CBCM is not enabled.

Hopefully this helps.

I was able to fix this for myself, but I’m not sure what caused it in the first place so I’m not sure how permanent the fix is or whether it’s even the same problem many of you are experiencing. So, apologies if this is not useful for you.

I’m using Ubuntu 22.04 with KDE and the appimage version of Obsidian (1.4.12) and external links were opening in Konqueror despite (the snap version of) Firefox being my default browser. No other app was causing this behavior.

I also installed the deb version of Obsidian with the same result, but got this on the console.
> org.kde.kfmclient: External browser service not known: "firefox_firefox.desktop"

kreadconfig5 reported Firefox (firefox_firefox.desktop) as my default browser as did xdg-settings. However, when I went to the GUI for System Settings, it strangely reported Konqueror. I set this to Firefox and it worked in Obsidian.

I believe I originally set my default browser through Firefox’s prompt to be the default browser. My best guess is that Firefox did not do this correctly, so it was only partially set as my default browser.

Edit: Just to add, this fixed the problem for me in both the appimage version and the deb version. I have not tried the snap version.

Take a look to this tiny program , maybe it can help.

Simply assigns different protocols to different browsers

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.