Export to pdf creating extra files named <file>-1.pdf, <file>-2.pdf

What I’m trying to do

I want to stop the PDF export from automatically renaming the exported PDF files with “-1”, “-2”, … everytime I export an updated version.

This just creates a lot of extra files that I have to find and delete, and then rename the last file to just be the file name… lots of unnecessary work.

This just started happening recently – I used to be prompted to replace the file which is exactly what I want for my use case.

Things I have tried

  1. searched the forum under “PDF and rename”
  2. searched the help docs
  3. searched settings/PDF export to see if there’s an option to put this back like it was

Are you using a plugin? I don’t think the core PDF export has a settings area. If you are using a plugin, I’d file the question as an issue on its GitHub.

The closest thing I see to a relevant setting is Settings > Files & Links > Confirm file deletion. There’s a small chance that might also control confirmation of overwrite.

Thanks for the reply; I’ve got the image rename plugin, but I was using that long before the issue started. I’ll remove and and see if that’s involved.

Duh… that was it. I’ll file a request with them.

Thanks much!

FYI… in the latest version (1.4.0) they added a feature to “Handle all attachments” which is turned on by default. Turning this option off reverts to the original behavior.

You can also write a RegEx to exclude certain files… like PDF files in my case.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.