Excaldraw plugin working on some devices but not others in same vault

i have an obsidian vault which i sync across 2 mobile devices and one desktop using syncthing. i have the excalidraw plugin working on the desktop and one f the mobile devices, but not the last device. it installs ut displays the messsage 'dailed to load/unload obsidian-excalidraw-plugin.

i ries using the extension in a seperate vault on the dveice that isn’t working and it was still not functioning, so the problem is with the device/app itself not the vault. i uninstalled and reinstalled the plugin ultiple time. i deleted the contents related to it in the .obsidian directory (on all devices). i uninstalled the obsidian app of my device entirelya and reinstalled it to no benefi still. nothing worked.

i am running obsidian version 1.5.11 on all three devices and excalidraw version 2.0.25. the desktop is running fedora linux, adnd the two mobile phones are running android. the non functioning one is running huawei’s harmony OS 2 (a google-less android skin)