Escaped numbered list shows backslash in reading view

Steps to reproduce

Use backslash to escape numbered list processing.
e.g.

\1. this is sample text
\2. this is more sample text

Did you follow the troubleshooting guide? [Y/N]

Yes - Results were the same in the Sandbox Vault as were in my Vault with and without plugins enabled.

Expected result

Lines starting with a number and period would render as plain text rather than being processed as a numbered list.

Actual result

  • In the edit view, the lines render as expected - with the backslash visible only when directly editing that particular section.
  • In source mode, the lines render as expected, with the backslash visible.
  • In reading view, the backslash is visible everywhere, which is neither expected nor desired.

Environment

Windows 11 Pro, 23H2 22631.3235, Windows Feature Experience Pack 1000.22687.1000.0
SYSTEM INFO:
Obsidian version: v1.5.8
Installer version: v1.5.8
Operating system: Windows 10 Pro 10.0.22631
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 21
Plugins enabled: 0

RECOMMENDATIONS:
none

Additional information

Reading View Screenshot

Screenshot 2024-03-07 135709-ReadingView

Source Mode Screenshot

Screenshot 2024-03-07 135803-SourceMode

Edit View Screenshot

Screenshot 2024-03-07 135820-EditView

Try moving the slash between the number and the period.

1\. this is sample text
2\. this is more sample text

https://spec.commonmark.org/0.31.2/#backslash-escapes

1 Like

AHA! - so, not a bug. Rather the one instance where the escape isn’t going to behave as you’d expect unless you REALLY understand the spec!

And thank you for including the reference link. Brings the explanation around full circle AND gives me the source material I was missing and wish I’d had with this and other formatting questions!

Greatly appreciated! :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.