Error: Out of Range for Changeset

Since the latest update I have been receiving this error for some of my notes:

Failed to load {filename}. Position {number} is out of range for changeset of length {number}.

Md file opens fine with other apps. Any idea on what this is and how to correct this?

thx

Does this still happen if your community plugins are toggled off?

Does this happen in Source View, Reading View, and Live Preview, or just some of them?

I am running into the same issue as well … Any idea why this might be happening?

I was having this problem as well. No idea what was causing it but I wanted to see if it was a plugin issue so I turned restricted mode on (i.e. disabled all plugins at once). This solved the problem and I could open the problematic files. I then turned off restricted mode as I was going to start debugging the plugins one by one and amazingly the problematic files open with all plugins enabled. So yeah - try turning it off and on :joy:

I’m having the same problem, and it extends to creating a new note:

Failed to load “Untitled.md”. Position 1333 is
out of range for changeset of length 0

The problem went away when I disabled “Drag-n-Drop for blocks” community plug in

2 Likes

Disabling “Drag-n-Drop for blocks” fixed it for me too, good catch.

I stopped using that plugin a few weeks ago anyways because it’s easier to just put a footnote tag ( There’s a page in the sandbox help vault called Footnote that explains it ) at the end of bulleted lines to embed them in other notes by doing ![[note-name#^flag-name]]. You don’t have to actually add a footnote entry elsewhere in the document to be able to embed them like this. Also, the square brackets seem to be optional when using them like this.