Error message in dataview: Unrecognised query operation folder

I am new to dataview and am using it to show files linked to a particular index file. I use a template when creating files, so this shows up in the search which I don’t want so trying to use a straightforward query:

list from [[]] and !outgoing([[]])
from -"Templates"

The list view works fine but when I add in the from line I get an error message:

Dataview: Unrecognized query operation ‘negate’

If I take out the minus symbol in front of the folder I get a slightly different error:

Dataview: Unrecognized query operation ‘negate’

I’ve tried checking for updates for both the plug in and obsidian but all up to date, tried restarting, tried the full folder address, nothing works at all. Tried searching but the only thing that shows up is a Reddit comment from a year ago that was deleted! I know I’m doing something wrong but no clue what that is?

If this works, can you adapt it to your vault and needs?

FROM ([[#]]) OR outgoing([[#]])
AND -"Templates"

That got it! I get it now, I was doing the FROM command twice in my original query, that’s one to learn from, thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.