Enable forward linking (when searching) in the main graph view

Hi

On the main graph view, when searching for a note (A), the search results will return a map of note A and other notes which mention note A (backlinks). However, the search will not show notes that A mentions e.g, note B (forward links), unless note B also has a backlink to note A. The forward link disappears.

So, the main graph view (when searching for a specific note) can only show backlinks to the specified note but not the specified note’s forward links. The forward link disappears from the main graph view.

However, this issue does not seem to occur on the local graph view as when searching for note A it showed forward links to note B, (when note B didn’t have any backlinks to note A)

My question is, can I change a feature on the main graph view (when searching for a specific note) to show the note’s forward links as well as its backlinks? (like the local graph view). I have enabled ‘outgoing links’ on the core plugins but that doesn’t seem to work.

Any help would be greatly appreciated.

Thanks

When you say “searching” in a graph view, do you mean the box under the “Filters” portion of the settings (i.e. below it are buttons to display or not “Tags” “Attachments” “Existing Files Only”)? That one does not behave exactly like a regular searchbox, it is instead filtering the visibility of graph nodes based on the contents of the box. I use it to remove a couple of files and folders from my global graph that would otherwise clutter what I want to see (e.g. -path:templates). If I put a piece of text in there e.g. “Read” it is going to show me only the notes that have the word “Read” in them, and if they happen to be connected it’ll draw the arrows. (Exception: it also seems to be showing non-existing files linked off of the notes it is showing when I toggle that setting. I don’t know why! They can’t have the word “Read” in them if they don’t exist.) One of my notes has “Read” in its title, so all of its backlinks will show up because they definitely contain the text “Read”; it’s in a link to that note. Its outgoing links (to files that exist) mostly do not appear because the files it links to do not contain the word “Read” in them. Does that help clarify what is going on?

My local graph seems to behave the same as my global graph, I couldn’t reproduce your different behavior there.

If I want to “search” for a note in the global graph, I might use the Groups settings to temporarily color that note to make it easier to find in the graph (the search boxes here work like the ones in the Filters section, you can type file:NameOfYourNote to color just one file). Or use things in Filters to get rid of lots of other notes, center my view of the graph over the note I’m looking for, and then clear out the Filters to make things appear again.

Ok great thank you for clarifying this - so because the main graph view is only showing notes with the search term in the note it would be unable to display a notes forward link if it does not contain the search term.

I have also had the same exception with the non-existing notes still appearing even if they don’t have the search term in the note. Also, I checked my local graph again and it can show forward links for the highlighted note, if there is no search term inputted into the search box, so does in fact behave like my global graph, like what you found.

Thank you for letting me know how this works.

1 Like