Emacs shortcuts is interfering with unicode outputs


Whenever I press a key that sends the Unicode for “ø”; the cursor moves to the end of the next word and then outputs “ø” at that location. This means that is is impossible for me to write in my native language. Obsidian is the only program in which this occurs.
It does not occur for other Unicode characters (reason explained below).


In all other apps:

I am trying to edit this text to output:  ø
But it only works outside of obsidian

In obsidian:

I am trying to edit this text to output: 
Butø it only works outside of obsidian

In all other apps:

I am trying to edit this text to output:  Ø
But it only works outside of obsidian

In obsidian:

I am trying to edit this text to output: Ø only works outside of obsidian

Reason for the problem

ø in unicode is ALT+00F8. ALT+F moves the cursor to the next word in emacs and cannot be disabled. Similarly alt+D is also a emac shortcut that interferes with the desired unicode output

Solution to the bug

the user should be able to disable emac mode or Obsidian should behave similarly to other apps in this regard.

My temporary solution


  1. quit using Obsidian
  2. Write language-specific keycodes through the language settings but this requires a reprogram of my keyboard and I will simultaneously lose the ability to output greek alphabet, emoticons, and other cool stuff. (The keyboard is running QMK firmware btw in case anyone is interested in fully programmable keyboards :sunglasses:)

I am very confused by this report
There is no emacs mode in Obsidian.

I should have specified that sorry. Emacs shortcuts is enabled globally in macOS and can not be turned off. Theres a list here: https://www.hcs.harvard.edu/~jrus/site/system-bindings.html

The problem is that ALT is also the unicode toggle key. But this is not a problem in any other apps.

If i type ALT + 00F8 then Obsidian will recognize alt+f as well as the unicode so it moves the cursor before outputting ø. No other app has this behavior in macOS.

edit: for further clarification. I have a key that functions as a macro sending: ALT + 00F8 when pressed.

OK, this is a very unconventional setup.

We don’t do anything special with characters.
Not sure if this problem is shared by other Electron-based apps or only by those who use codemirror.

Perhaps, this problem will be solved when we upgrade to a more recent version of electron.

Its a very specific problem, but it will not be unique to me. I bet every QMK keyboard user will have a variant of the same problem.

I’m not a programmer. Discord is Electron-based right? I do not have this problem in Discord.

I will need to further research QMK framework, but do you use American Qwerty layout?

Emacs keyboard layout for navigation is based on control ⌃ with either F B N P A or E (frward backward next previous alpha end). alt ⌥ only modify the ⌃F or ⌃B to move by word not characters.

I use that convenient keybinding for all possible (navigating inside iA Writer, choose next/previous link in browser address bar/spotlight, or even navigating inside Obsidian before I found out the tweak to further enhance Vim keybindings).

If I test in my keyboard, ø is triggered with ⌥o, so it might be QMK framework’s fault, that you might be able to overcome with Karabiner-Elements

I’m also replying to confirm that Obsidian is not acting in a conventional way compared to other apps on MacOS, with any keyboard. (I have a standard Mac keyboard, US ISO layout, set to Canadian English.)

Hitting alt (option) plus other letter keys usually will trigger special characters or accents in MacOS in English.

In Obsidian:
alt-d deletes a line.
alt-f moves forward.
alt-b moves backwards.

In every other text input field in MacOS alt-d, alt-f and alt-b would output ∂, ƒ, and ∫ respectively. (In Canadian English. I haven’t tested any other locales, languages, or Greek, etc.)

1 Like