Editor: End of Document Footnote parsing problems

Steps to reproduce

  1. Make a footnote with only a URL as content
  2. Create a second footnote below with three words

Expected result

The text in the second footnote should all be the same color

Actual result

The second word in the second footnote has the same color as the link above

Environment

  • Operating system: MacOS 10.15.7
  • Obsidian version: 0.9.3

Additional information

I think it’s related to the link in the first footnote.

Here’s a gif that shows that by adding a single space after the footnote URL.

Note how the word “particular” in the second footnote changes when I add a space at the end of the first footnote.

footnote-bug

2 Likes

that’s a strange bug, does it affect functionality or only style?

Hi! As far as I can tell it’s only formatting.

1 Like

got you, I’m on linux so I can’t tell for sure if it could be a mac bug.

You might have already done this, but try testing other obsidian community themes, perhaps there’s something wrong with the obsidian.css of the theme you are currently using.

When I use two asterisks to apply italic style to my first footnote, all the text following the second asterisk become italic as well, even including the next footnote:

May or may not be related:

Can confirm on 0.11.13

Probably just some Markdown rendering quirk.

Footnotes in Markdown can be multi-line, so each should be terminated with a blank line, or at least a forced line break (two spaces at the end of a line).

I think. :wink:

Steps to reproduce

  1. create a footnote;
  2. add to the footnote a link to the file present on the local computer.

Expected result

The link will be highlighted and you can click on it either with your mouse (ctrl+mouse1) or with your keyboard (alt+enter).

Actual result

Invalid link

A similar problem is observed with external links to websites. Steps to reproduce:

  1. insert a link to a website;
  2. add a one-word description to it;
  3. make sure that this link will not work;
  4. but if you add at least one space to the link, the link becomes working.

image

Environment

  • Operating system: Windows 11
  • Obsidian v.: 0.13.23

Additional information

I have reproduced this problem on computers running win10/11 on clean and personal builds.

The first word in a footnote does not have formatting applied in Live Preview mode.

Steps to reproduce

Create a footnote with the [^1] and [^1]: text syntax.
Try to use formatting (bold, italic) on the first word of the footnote.

Expected result

The words should be formatted correctly.

Actual result

The first word has no formatting applied.

Live Preview:
grafik

Reading mode:
grafik

Environment

  • Operating system: Linux
  • Debug info:
SYSTEM INFO:
	Obsidian version: v0.13.24
	Installer version: v0.13.24
	Operating system: #1 SMP PREEMPT Sat Jan 29 12:57:02 UTC 2022 (b146677) 5.16.4-1-default
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Safe mode: on

RECOMMENDATIONS:
	none

A post was merged into an existing topic: Inline footnotes and links

Steps to reproduce

In Live Preview mode, add a footnote with a link immediately at the start.

Expected result

It should look like a link.

Actual result

It only shows source code, unless you add another character between the colon and the square brackets:

image

Source:

[^3]: [link](https://forum.obsidian.md/) not rendered as link
[^4]: a [link](https://forum.obsidian.md/) properly rendered as link

Both render fine in Reading mode.

Environment

Obsidian 0.14.0 (also 0.13.33) on macOS Big Sur.