Edit Mode ≠ Preview Mode w/list of local-links


Steps to reproduce

Formatted my downloads folder files to .md format with file names and links to the files.
In the edit mode, all is well. In Preview, not so much. I’ve tried a number of things to resolve this.

  • Identify any difference in formatting…
  • Adding space, removing space, adding %20 in spaces, etc. …
  • If there’s an error in my Markdown, I can’t find it.
    But the Preview ≠ Edit mode.

Expected result

Edit Mode = Preview Mode

Actual result

In the Edit mode, everything appears to work great.
In preview mode, some links are ok, others not.


  • Operating system:
  • Edition: Windows 10 Home

  • Version: 1909

  • Installed on: 9/17/2019

  • OS build: 18363.1016

  • Processor: Intel® Core™ i7-3770 CPU @ 3.40GHz 3.40 GHz

  • Installed RAM: 32.0 GB

  • System type: 64-bit operating system, x64-based processor

  • Obsidian version:v0.8.4

Additional information

Local “file” links must be url-encoded meaning they cannot have spaces in them. Replace the spaces with %20.

And remove “Dynalist” from the first link.

Oh, I see you mentioned adding %20 to spaces, but that does seem to be the problem in your screenshot. Can you provide a screenshot where you’ve fixed this to confirm there is a bug?

You’re right! I missed a %20 each time I tried them. 2020-08-25T00:09:00Z :fist_right:t2: :smiley:

I ruled out Dynalist already. :innocent: They want $8/mo and there’s only one feature I want on the Pro list. 2020-08-22T07:00:00Z :stuck_out_tongue_winking_eye:

Obsidian is running way ahead of the others. I was a bit miffed I couldn’t create a check list. I haven’t figured it out, or it isn’t there. If I could put the checklist (like Dynalist) You would have noticed Dynalist was one I checked off to be deleted. :stuck_out_tongue:

Oh… FICO = 844

Oh good, glad you got the links figured out :smiley:

You can create checklists in Obsidian using - [ ]. Check the Format your notes note in the help vault.

About your CC being declined, you can PM Silver about this.

Oh… Okay!.
Error 1. no - before the [ ]
Error 2. Entire list was indented

Discovery 1. - must be the first item (not indented, against the left margin)

Thanks Sam. The CC issue is being resolved. Long story. Point was I’m in with Obsidian.