Dragging URL etc. onto Canvas

Things I have tried

What I’m trying to do

Happy new year all! I’m sure this is a simple one but it is driving me crazy: When I drag a URL or other file onto Canvas I just get a card that says the filename (see example) rather than a transcluded version that others seem to get. Is it a setting somewhere? Thank you.

Example

Drag a URL from where? An actual .url file on your computer?

I think what others are doing are dragging URLs from the location bar in their browser. Or copy a URL address and paste it in Canvas.

If you are dragging a .url file, I think this behaviour makes sense. It is embedding the file itself. Maybe it should parse the file into a URL, but then someone would make a Bug Report saying they can’t embed a .url file. :slight_smile:

Thanks @rigmarole. Yes, I’m dragging the URL from the location bar in the browser and that doesn’t work - although I tried the copy and paste of the URL onto the canvas and that does work.

Similarly I can’t drag say a folder from windows explorer onto the canvas to create a shortcut. It shows ‘copy’ but I understood that others can drag from windows explorer to create shortcut link.

Ah, I tested Firefox in MacOS which works to drag the URL. In Firefox Windows, it makes a .url link. It might depend on the browser/OS. Or it might be something the devs can fix.

As for folders, you’ve seen someone link to a folder in Canvas?

You can hold down Ctrl while dragging a folder or file to make a link to it in a regular Markdown note. Perhaps linking to folders in Canvas is not supported (yet).

Belated reply, my apologies. It did work from Chrome but seems to be an issue dragging a URL from Firefox (on my set-up at least). Dragging a folder from windows explorer into a note was hit and miss. Pressing ctrl while moving still displays ‘copy’ rather than ‘move’ - some times nothing happens. I will try to do more tests…

It’s a little confusing because you’re talking about two things. Embedding files, vs. URLs.

For ctrl-dragging, I am talking about files. And yes, I experience the same issue. It still says “Copy” even when holding Ctrl.