Dragging attachment into note from Gnome Archive Manager creates 0-byte file (Linux)

Steps to reproduce

  1. Open a zip-archive in Gnome Archive Manager
  2. Drag a file from the Archive Manager Window into an open note in Obsidian

Expected result

A link to the attachment is created in the note and the attachment file is placed in the folder that is configured in settings.

Actual result

A link to the attachment is created in the note.
Instead of the correct attachment, a 0-byte file with the correct file name is created in the attachments folder.


  • Operating system: Arch-Linux (Kernel: 5.17.5-arch1-1)
  • Gnome Archive Manager is just “File Roller” distributed under a different name
    Version on my system: file-roller 3.42.0
  • Debug info:
	Obsidian version: v0.14.6
	Installer version: v0.14.6
	Operating system: #1 SMP PREEMPT Wed, 27 Apr 2022 20:56:11 +0000 5.17.5-arch1-1
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: on
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Safe mode: on


Additional information

I have attached a sample archive to reproduce this with: test-archive.zip (2.0 MB)
Of course, any archive can be used and as far as I can see, this affects all file types.

I tried to drag the files into other programs like Okular and Firefox as well and noticed that they don’t even accept files coming from Archive Manager. IMO, blocking files like this from even being dropped in would be a valid solution, as this is not an important feature and it would make clear to the user that the functionality is not supported.
The current behaviour is misleading and could cause data loss.

I tried to test this with other archive managers like Peazip and 7zip-gui, but they don’t even let you drag-and-drop files to other windows, so this issue doesn’t apply.

Thanks in advance for looking into this!

Thanks, open a feature request for this.