Drag and Drop Pages into Folder Stopped Working

I just created a couple of folders in the file explorer and successfully dragged and dropped some pages into them. Then I created another folder, and tried to drag some other pages into them, and nothing happens. I tried doing this with one of the earlier folders, and it still works. I though maybe the issue was the problem folder had the same name as a page (Reading), so I renamed it. No luck. So I deleted that folder and created another called “Library”, and still nothing will drop into it. The one thing I think might be a clue is that the items that would drag into folders are items that I created directly in Obsidian, and those that will not were imported from Roam. Any ideas?


Just found the problem. Obsidian will not let you create a page name with “:” in it, but will let you import names containing an “:” from Roam. As soon as I removed the “:”, the page could be dragged to a folder. It is rather annoying that when it comes to page names, which might be the name of a book, we cannot use some of the actual characters which might appear in the title. Is there no markup symbol that can be paired around a string that says “anything between these symbols is plain text, not markup language”?


Not with file names, as some operating systems wholesale fail to deal with certain characters. (I’m looking at you, Windows.)

I would suggest identifying a different character for these purposes, sadly.