Do you guys run into the issue that the editor window flash once in a while?

The software version is v1.0.3, MAC OS M1, Monterey 12.6
When I was editing a note, the editor screen will flash once in a while. The issue happens when editing some specific notes, not for all notes. But I don’t know what the reason is? please see the attached file
Untitled (2)

Can you please paste your “Show debug info” results here? (Run the command in Obsidian.)

Hi, I don’t see the “show debug info” command in obsidian with cmd+p

Well that’s strange. Are you on an extremely old installer version or something? If so, reinstall Obsidian from the website download.

I posted the result in “debug info”

SYSTEM INFO:
Obsidian version: v1.0.3
Installer version: v0.15.8
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 1
Restricted mode: off
Plugins installed: 29
Plugins enabled: 20
1: Code Block Enhancer v1.0.5
2: Cycle through Panes v0.1.0
3: Dataview v0.5.47
4: Notion-Like Tables v5.0.5
5: QuickAdd v0.7.0
6: Recent Files v1.3.3
7: Reminder v1.1.14
8: Style Settings v0.4.12
9: Tag Wrangler v0.5.5
10: Tasks v1.18.1
11: Advanced Tables v0.17.3
12: Calendar v1.5.10
13: Quick Switcher++ v2.3.2
14: Better Command Palette v0.14.0
15: Number Headings v1.10.0
16: Minimal Theme Settings v6.1.0
17: Advanced URI v1.30.0
18: Metadata Extractor v1.0.2
19: Media Extended v2.11.1
20: Quiet Outline v0.3.11

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

As I try to repeat the issue,

  • create a new note
  • create the some headers (such as ## level2) and add some content under those headers
  • in the same note, try to reference one of the above headers you just created, for example use ![[## level2] to open live view for the content
  • in the same note, try to input some content repeatedly, then it is most likely you see the screen flashing as you type.

Do you embed a section from the same note? Are you sure you want to do that, and not just link it? I’m reffering to doing the ![[...]] instead of just [[...]]

I can understand it flashing, if you keep wanting to repeat a previous statement, as each time you’ll edit anything it would need to re-add that section, or at least verify you’ve not changed it again.

I don’t have to, but sometimes it is a good way to reference a topic in the same note, especially when the note is long. Worse thing is every keystroke will lead to a flash which is very annoying.
If I use [[##]] instead of ![[##], then there is no such issue.

Well, imaging this analogy to your case: Consider a note as a stack of crates on top of each other, and somewhere in this stable you decide you want to insert a copy of a crate from below in the stack. Would you consider that a safe strategy?

What I’m trying to say is that, you should expect it to flash when you keep changing the content based upon the same content (although a different section). I would rather keep the pure link, and not the embedded version.

Even with just the reference to the section, you’ll get the option to preview what that section with the hover preview, and I reckon you’ll not get the current flash. Which is bound to happen as you keep changing the content, and Obsidian needs to reconsider what to embed, and then embed that section.

Try the following:

... some other text ...
## Level2
some text
... way down in the note ...
As discussed in [[#level]], you see some text when hovering the link

And I’ll repeat the potential solution. Reinstall Obsidian. Your installer is probably out of date. It might fix the problem.

Then make sure your themes and plugins are updated too. Then test turning community plugins off.