Display of dates incorrect after new Properties update

Once you’ve done the above, delete everything above this line.

Steps to reproduce

I have a number of notes with YAML date of created: and modified: These are scattered all through the vault and have typically been filled out manually My notes have them entered in YYYY-MM-DD format.

Now with properties I see the correct format in Source mode but the Preview mode changes it to mm/dd/yyyy

Did you follow the troubleshooting guide? [Y/N]


Expected result

Dates display in the format they are entered.

Actual result

dates are displayed in a different format


Obsidian version: v1.4.5
Installer version: v1.4.5
Operating system: Darwin Kernel Version 22.6.0: Wed Jul 5 22:21:53 PDT 2023; root:xnu-8796.141.3~6/RELEASE_ARM64_T6020 22.6.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: light
Community theme: Oogie
Snippets enabled: 4
Restricted mode: off
Plugins installed: 29
Plugins enabled: 23
1: Tag Wrangler v0.5.11
2: Dataview v0.5.56
3: Tasks v4.6.0
4: Natural Language Dates v0.6.1
5: Periodic Notes v0.0.17
6: Templater v1.16.0
7: Advanced Tables v0.19.1
8: Readwise Official v2.0.1
9: Calendar v1.5.10
10: Citations v0.4.5
11: Contextual Typography v2.2.5
12: Hotkeys++ v0.2.7
13: Kanban v1.5.3
14: Obsidian Charts v3.7.2
15: QuickAdd v1.2.1
16: Smart Random Note v0.2.1
17: Style Settings v1.0.6
18: Zotero Integration v3.0.9
19: Buttons v0.4.19
20: Actions URI v1.2.5
21: Pandoc Plugin v0.4.1
22: Better Word Count v0.10.0
23: Longform v2.0.3

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

From the sandbox vault test

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.