Display abnormal for multiline link

I believe previous version of Obsidian did not have the issue and only lately I noticed it:

If you have a link where the display text is on multiple lines, while the link still works, the display does not look normal.

Steps to reproduce

type in a multiple-line link, for example

[A long long text cannot be hold in one line
it has to go to the next lines
like this to Google link](https://www.google.com)

Did you follow the troubleshooting guide? [Y]

Expected result

A long long text cannot be hold in one line
it has to go to the next lines
like this to Google link

Actual result

[A long long text cannot be hold in one line
it has to go to the next lines
like this to Google link

Note the link still works, and the text from the 2 lines are underlined

Environment

SYSTEM INFO:
Obsidian version: v1.4.14
Installer version: v1.4.12
Operating system: Windows 10 Pro 10.0.22621
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 1
Plugins enabled: 1
1: Advanced Slides v1.20.0

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

Screenshot 2023-10-01 161853

I don’t think the editor ever supported this.
We definitely not support it for wikilinks.

Please, open a FR for standard markdown links. thanks

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.