Disconnected. Code: 1000 Normal Closure

Things I have tried

I am attempting to sync a large Obsidian directory.

  • It’s 1.8gb without PDFs and unsupported file types. I understand there is a 4bg limit to remote vaults over Sync.
  • The settings to sync PDFs and unsupported file types are turned off in the Sync settings panel
  • The vault on my desktop and my iPad are correctly connected to the remote vault
  • The vaults are both named identically

What I’m trying to do

This is the pattern that appears in the Sync log:
2021-09-04 16:41 - Waiting to connect to server
2021-09-04 16:42 - Connecting to server
2021-09-04 16:42 - Disconnected. Code: 1000 Normal Closure

are you behind a firewall?

No, I’m at home on my wifi network.

we had ISP blocking connections to github or DigitalOcean without user knowing. Do both your devices show the same stuff in the log? Can you try on a different network?

Hmm, maybe I can hop on my cell phone as a hotspot. The thing is both my desktop and iPad are on the same wifi network. I’m assuming both devices use the same protocol and connection. Anyway, I’ll try that out.

I tried the hotspot and got the same result. Just to rule it out, I restarted my desktop and tried again and I still get the same error.

I realized, also, I failed to mention that I have a couple of other, much smaller vaults that are syncing correctly. It would be useful to know exactly what that error means, but I suspect it has something to do with vault size and I’m overlooking something.

I’ve done some further testing. I cloned the vault and started deleting directories. It started working when I deleted .obsidian.

I then cloned the entire vault again and turned safe mode on and the sync worked.

I turned off all plugins and the sync worked so I made my way through all the plugins, one by one. I turned them all back on at the end and the sync is working. Not sure what happened. Maybe the remains of an old plugin I had removed?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.