Disappearing extra = in highlight

Steps to reproduce

  1. Type ===Foobar===

Expected result

=Foobar= highlighted.

Actual result

Foobar highlighted.

Environment

SYSTEM INFO:
Obsidian version: v1.4.14
Installer version: v1.4.14
Operating system: Darwin Kernel Version 22.3.0: Thu Jan 5 20:49:43 PST 2023; root:xnu-8792.81.2~2/RELEASE_ARM64_T8103 22.3.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

Additional information

Even though this is a bug report, the fix I would like is that different numbers of = were mapped to different highlight CSS classes, say cm-highlight-<n>, so that we can set different colors for each one. This is a reasonable text-only syntax also, ====foobar==== > ===foobar=== > ==foobar==.

Confirmed on iPad.

That’s more of a feature request, and unfortunately also a non-standard syntax.

Well, it’s as non-standard as ==xxx== is, but at least:

  1. It’s not an entirely new deviation of the standard.
  2. Even as pure text, it conveys the idea of a different level of emphasis.

That said, it was just a comment about a possible resolution to the bug, but I don’t really feel like opening a FR just for this.

It’s more non-standard — the == extension to Markdown is recognized by at least a few other apps (that I know of: iA Writer, Pandoc (as an option), and the Markdig processor).