Deactivate Auto-Text-Replacements/"Smart Dashes" from MacOS for Obsidian

Hey guys. MacOS has this Auto-Text-Relpacement function that can only be deactivated within an application and not globally for certain replacements like long dashes (automatically out of two small ones like “–”)
The menu within notes lookes like this (sorry for german, below is another screenshot)
Bildschirmfoto 2023-12-14 um 16.51.55
Within Apple’s own Notes App there is the possibility to deactivate this function. Within Obsidan the replacement takes place as well but I cannot deactivate it (as suggested by the MacOS manual): Replace text and punctuation in documents on Mac – Apple Support (UK)

What I’m trying to do

I would like to deactivate “smart dashes” in MacOS for Obsidian (because right now every - - > (without spaces) automatically becomes thsi doouble-arrow ⇉ which totally destroys Mermaid Syntax)

Things I have tried

  • deactivate all Plugins in Obsidian that might also cause the problem (especially smart typography)
  • deactivate all auto-replacements in the Keyboard-Settings on MacOS (but the problem persists as there is no global setting for that but apple refers to per-app settings int the edit-menu of an individual app)

Sorry if this has already been solved elsewhere - help would very much be appreciated.

Cheers!

I don’t see that behavior in the Sandbox vault, and Smart Typography should give you control over that. Try changing your font — some fonts (including Obsidian’s former default font) have ligatures that do things like that.

I can confirm that, in my sandbox vault the problem is gone. So it must be something I’ve done. I’ll report what it was as soon as I figures out what caused it. Thanks!

Edit: Stupid, stupid me. I missed that I had a plugin installed which is called “arrows”, that did cause my problem (so it was in fact a feature and not a bug). Solved now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.