Date not rendering in frontmatter

What I’m trying to do

I am trying to get the date created to render in the frontmatter. It works in my daily note and other notes where I have templates, but not in my Zotero template. I am using the syntax:

created:: {{date}}

When template called, it renders as:

created:: 1578834000000

Things I have tried

Searched the help and online but couldn’t find any answers. I tried shifting the order of the frontmatter and using 1 colons instead of 2.

That kind of looks like a Unix Timestamp, in other words seconds since 1970, so you might need to specify a date format to that template function.

1 Like

Thanks for the response. I found the problem.

Because I was using a template for Zotero import, the syntax had to be in that format. So, the following worked without issue.

Date created: {{importDate|format(“YYYY-MM-DD”)}}
Date modified: {{importDate|format(“YYYY-MM-DD”)}}


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.